Thermocouple randomly shows 2000°



  • Hi, I have a setting with a duet wifi + Thermocouple Daughter Board and two PT100, one per extruder. I have the left extruder that randomly is showing 2000 degrees.

    here some details:

    • it may work for long time with no issues (several days) and at a certain point is showing this issue
    • Most of the times I just restart the 3D printer (even with no movement of the axes) and the message disappear
    • sometime it stay there, I try multiple times with no result
    • when happen, I try to move the cable to understand if any short circuit but looks to have no results
    • I tried multiple times to unplug and plug again the sensor to the Board, with no changes

    any Idea?



  • @Marco_76 2000*C is a sign of open circuit I belive, so check wires and connectors.



  • @BoA Thanks for the feedback. Yes I know but there is no option of open circuit: the PT100 is a unique cable of 70 cm, and I soldered an extension of other 40 cm cables which are going directly to the Board 😞



  • @Marco_76 said in Thermocouple Daughter Board + PT100 randomly shows 2000°:

    Most of the times I just restart the 3D printer (even with no movement of the axes) and the message disappear

    -> try if it reappears by checking each axis alone: E.g. x-axis (only home x), if not, first disable (M18) all steppers again, then y-axis (only home y), if not...

    Especially check alone on the extruder if it is something there



  • @Marco_76 said in Thermocouple Daughter Board + PT100 randomly shows 2000°:

    @BoA Thanks for the feedback. Yes I know but there is no option of open circuit: the PT100 is a unique cable of 70 cm, and I soldered an extension of other 40 cm cables which are going directly to the Board

    Have you verified it by measuring the resistance in each wire?



  • @Marco_76 said in Thermocouple Daughter Board + PT100 randomly shows 2000°:

    there is no option of open circuit

    Belive, there is 😉 It is possible that the cable just started breaking internally, and this will get worse until there will be no connection at all. Been there 😉


  • administrators

    I presume you mean you have a PT100 daughter board, not a thermocouple daughter board.

    When you get the 2000C reading, send M305 P# if running RRF 2.x, or M308 S# if running RRF 3.x, where # is the heater (RRF2) or sensor (RRF3) number. In the response, what does it give as the "last error" ?



  • @dc42

    Sorry I messed.
    I have a Thermocouple Daughter Board + 2 K thermocouples

    forget the PT100


  • administrators

    @Marco_76 said in Thermocouple Daughter Board + PT100 randomly shows 2000°:

    @dc42

    Sorry I messed.
    I have a Thermocouple Daughter Board + 2 K thermocouples

    forget the PT100

    OK, getting the last error report using M305 or M308 still applies.

    Which version of the thermocouple daughter board do you have?



  • @dc42

    Here the error
    Heater 0 uses Thermistor sensor channel 0, last error: sensor not ready, T:100000.0 B:4138.0 C:0.00e+0 R:4700.0 L:0 H:0

    Sensors are E3D K-Type Thermocouples
    The Board is the latest I think using MAC31856

    Thanks


  • administrators

    Heater 0 evidently uses a thermistor. In the M305 or M308 command, please the heater number that corresponds to the thermocouple channel that gives the 2000C reading.



  • @dc42

    The physical sensor is definetly a E3D K-Type Thermocouple. Do you mean that I configured wrongly the sensor in config.g?


  • administrators

    Please post your config.g file.



  • @dc42

    by reading config.g I realized that I run the check on P0 which is the bed and not the heater. Sorry again.
    In fact in config.g I have the following.

    ; Heaters
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0 (bed)
    M143 H0 S100 ; set temperature limit for heater 0 to 100C
    M305 P1 X150 ; set thermistor for heater 1 thrugh the extended mini board
    M143 H1 S280 ; set temperature limit for heater 1 to 280C
    M305 P2 X151 ; set thermistor for heater 2 thrugh the extended mini board
    M143 H2 S280 ; set temperature limit for heater 2 to 280C

    by reading hetaer 1 with M308 P1 I get this message:
    Heater 1 uses Thermocouple (MAX31856) sensor channel 150, last error: sensor short to other wiring, thermocouple type K, reject 50Hz


  • administrators

    It says there is a short to some other wiring. if you look at the thermocouple daughter board, you may find that the LED for that channel is lit. Here are some possible reasons:

    1. You genuinely have an intermittent short circuit between one of the thermocouple wires and something else, most likely the hot end metalwork.

    2. You have electrostatic discharge between something (most likely the hot end metalwork) and a thermocouple wire. This can happen quite easily because extruding plastic may build up static charge. The fix is to connect the hot end metalwork to Duet ground, either directly or via a high value resistor. Alternatively you can connect the hot end metalwork to the heater+ or fan+ wire using a high value resistor, e.g. 1Mohm.

    3. The thermocouple wires are picking up a lot of interference from another cable, most likely a stepper motor cable. Avoid running the thermocouple wires n the same bundle as stepper motor wires. If you can't avoid it, use twisted pair wires for the stepper motor, and shield either the thermocouple wires or the stepper motor wires.



  • @dc42

    Thanks. I tend to exclude option 3 as I get the message immediately when I switch on the 3d printer, without any movement of steppers. Also, there is a flex3drive system, so the extruder is far from the sensor. I will investgate 1 & 2 and be back to you.



  • @dc42 Thanks option 1 worked: I Moved the thermocouple a bit out of the e3d hotend (2mm) and now works well.

    I'm puzzled as the sensor (which is the e3d one) has a shilding which should avoid any contact with the hotend. Looks like the trial and error of Windows: restart and looks if it is fixed 🙂

    By the way thanks for your help, as always you are fast and to the point!

    Top!



  • Just an update for the benefit of the community. I got again the error and I fixed with solution 2. I temporarly put a cable attached to the ground, and when I switch on the 3d printer, if showing 2000 degrees, I just connect hotend to the ground and reset the heater. I will do a more stable solution as suggested by dc42.

    Thanks!


Log in to reply