How power on fans on print head?



  • Hi,
    I am using software slicer (Simplify3d), and when print, only power on Small fan, of 3 in print head.
    How select that other two fans power on… in Simplify, in Cooling there is nothing....



  • I was reading Wiki…. and see my "CONFIG.G", i have this:

    [[language]]
    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off; Custom settings are not configured
    
    
    • I suppose that M106 P1, correspond to small fan, its thermostatically controlled, power on when temperature > 45º
      But the others… how i can make Slicer power on? maybe...
    [[language]]
    M106 P0 S1 I0 F500 H1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off; Custom settings are not configured
    
    

    Not sure…. Can someone help me?



  • Here s my config.g for the fans

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off (print fan)
    M106 P1 S1 I0 F500 H1 T60; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on (heatsink hotend fan)
    M106 P2 S1 I0 F500 H-1 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned off

    Make sure you have the fan for the heatsink of the hotend connected to Fan1 and the blower fans witch blows over the printed part on Fan0 on the Duet board. Then go in simplify3d and enable the cooling. The blower fans should turn on at the second layer of printing



  • Also to check if the blower fans are functional you can send trough web interface or from LCD->console M106 S1. They should turn on. If you send M107 they should turn off



  • well…. some advances

    i have this section in Config->Fan

    [[language]]
    ; Fans
    
    M106 P0 S0 I0 F255 H-1; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F255 H1 T60; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S0 I0 F500 H-1; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned off
    ; Custom settings are not configured
    
    

    With this config….. the behavoir is next:

    I remember i have a Tevo Little Monster, with 1 small fan, and 2 médium fan in nozzle...

    A) Small fan Works.... its conected to FAN1, when nozzle arrives 60º, fan power on.
    B) 1 médium fan, conected to FAN0, works. When printer start layer 2 (setup in slicer) fan power on...
    C) BUT, the other médium fan, conectec to FAN2, don't work....., it's supposed power on, when printer start layer 2, as FAN0

    Things:

    • Slicer, no have options to control 2 layer fan, only have option to power on layer fan when reach layer 2 (don't is clear if is FAN0 or FAN2, or two FANs)
    • I have changed fron socket FAN2 and FAN0, and two fans works.
    • In the original board, 2 fans, was connected to same sockect, bridged
    • Its correct, in M106 P2, F500, while in M106 P1, F255?

    Its supoossed 2 layers fan, must power on, on layer 2 even if the filler does not have control over them?
    Ideas?



  • As you have discovered, M106 with no parameters will default to use Fan0. Slicers usually insert simple fan commands such as M106 S255. The S parameter is speed but there is no "P" parameter so it will default to using Fan0 . So to control Fan2 via the slicer separately to Fan0, you need to somehow get it to insert M106 P2 Snnn commands into the gcode and I have no idea how that could be done. One way which would be a little laborious would be to use a text editor on the gcode file and do a search and replace (search for M106 and replace it with M106 P2). But you'd have to ensure that the first layer still uses Fan0 and you'd have to do this on every gcode file. I don'y how S3D works but it may be possible to write some rules that would do this automatically.
    HTH

    Edit. I use Slic3R and have quite powerful part cooling fans but it is possible to set rules for active cooling which will control the fan speed depending on what is happening with the print (i.e small or thin parts, bridging etc). I would guess that S3D has the same facilities so maybe a better option for you would be to wire both part cooling fans to Fan0 then set up S3D for active cooling. In this case, it will insert commands in the M106 Snnn where nnn is the fan speed. So for example you might have M106 S64 for the first layer which will run all the fans connected to Fan0 at 1/4 speed, then for the second layer M106 S255 which will run them at full speed.



  • Big problems… Big solutions...

    I have connected in the same socket, fan and fan 2


  • administrators

    Another way of having the slicer control 2 fans as one is to use fan mapping in the tool definition command, like this:

    M563 P0 H1 D0 F0:2

    The F0:2 bit means that when the tool defined in that command is selected, if the slicer send a M106 command without a P parameter (fan number), it will be applied to fans 0 and 2.



  • Best option, i use that



  • @dc42:

    Another way of having the slicer control 2 fans as one is to use fan mapping in the tool definition command, like this:

    M563 P0 H1 D0 F0:2

    The F0:2 bit means that when the tool defined in that command is selected, if the slicer send a M106 command without a P parameter (fan number), it will be applied to fans 0 and 2.

    So to achieve what the OP wants, I guess he could create two tools thus M563 P0 H1 D0 F0 and M563 P1 H1 D0 F0:2. Then all he needs to do is (somehow) get S3D to insert T0 for the first layer, then T1 for the rest of the print.


  • administrators

    @deckingman:

    @dc42:

    Another way of having the slicer control 2 fans as one is to use fan mapping in the tool definition command, like this:

    M563 P0 H1 D0 F0:2

    The F0:2 bit means that when the tool defined in that command is selected, if the slicer send a M106 command without a P parameter (fan number), it will be applied to fans 0 and 2.

    So to achieve what the OP wants, I guess he could create two tools thus M563 P0 H1 D0 F0 and M563 P1 H1 D0 F0:2. Then all he needs to do is (somehow) get S3D to insert T0 for the first layer, then T1 for the rest of the print.

    Good thinking!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.