E Stepper



  • Looking for some help related to my E Stepper that runs my E3D Titan

    This is the model of stepper im using its a small nema 17
    http://www.motors-biz.com/item/894522/nema-17-single-plane-shaft-2-phase-bipolar-4-wires-stepper-motor-price-17HS0401-24B.html

    I triple checked the wiring and the left two wires on the connector are for one coil and the right two wires are for the other coil
    currently when i try and drive the motor it vibrates and get very hot

    I have also tried switching one coil pair incase they are fighting each other

    max Current Phase is 0.8A

    I have tried with 600Mah with no difference
    I cant get this thing to turn
    it moves easily by hand

    other code i use related to this motor

    M569 P3 S0 ; Drive E3D Titan goes backwards
    M350 E16 I0 ; Configure microstepping without interpolation
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M92 X200 Y200 Z800 E418.5 ; Set steps per mm
    M566 X900 Y900 Z12 E100 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z360 E1800 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z250 E250 ; Set accelerations (mm/s^2)
    M906 X800 Y800 Z1200 E400 I10 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    Running 24v power



  • I ended up replacing the motor. now it works


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.