Disable extruder endstop



  • I've got a delta printer, nothing connected to the extruder endstop. But in the machine properties the extruder endstop is listed as hit, which means I can't extrude anything.

    How can I invert or disable the extruder endstop?



  • Ok, I just created a plug to connect the two outside pins of the Extruder endstop together. That way it's inverted...


  • administrators

    disable filament out sensing on the extruder and that should clear up the issue:

    https://duet3d.dozuki.com/Wiki/Gcode#Section_M591_Configure_filament_sensing



  • Thank you very much!


  • administrators

    By default, extruder endstops don't do anything. The usual reasons for not being able to extrude are:

    • no tool selected (so it doesn't know which extruder drive to use);
    • tool not heated and cold extrusion not enabled.

    In either case there should be an error message on the GCode Console page od Duet web Control.

    HTH David



  • Yeah, seems like it. Initially I was just confused of the endstop being listet as "hit", so I thought I could never print that way. Therefore I never even tried to extrude or print anything. I thought the "safest" way to get a print going was just to create a "jumper" for that endstop.

    I'm thinking about disabling the cold extrusion prevention, but I'm not sure if I want to do that, because it's kind of a safety feature. Although it probably doesn't cause much harm to cold extrude. I don't have a geared extruder so it will just keep slipping and losing steps until I can shut off the printer noticing my fault 🙂


  • administrators

    @adras I would leave cold extrusion prevention turned on - that way you get an error message if you try to extruder with the hotend cold.


Log in to reply