BLTouch was working and now isn't.

  • So i had a month or so not using my printer, went back on today and tried to reset the bltouch pin using a macro.

    M280 P3 S160 I1

    it returns;
    M98 P0:/macros/Reset BLtouch
    Error: Invalid servo index 3 in M280 command

    Nothing has changed in my config so i have no idea what has gone wrong.

    M307 H3


    M307 H3
    Heater 3 model: gain 340.0, time constant 140.0, dead time 5.5, max PWM 1.00, calibration voltage 0.0, mode PID, inverted no, frequency default
    Computed PID parameters for setpoint change: P13.4, I0.482, D51.4
    Computed PID parameters for load change: P13.

    It's a pain as i am keen to get printing again.

  • administrators

    It sounds to me that the command M307 H3 A-1 C-1 D-1 is missing from your config.g file.

  • M307 is there however i had it configured to this

    M307 H3 A465.7, C176.6, D3.2 S1 ;
    M558 P5 X0 Y0 Z1 H5 F120 T2000
    G31 X32 Y10 Z2.9 P25

  • @dc42 said in BLTouch was working and now isn't.:

    M307 H3 A-1 C-1 D-1

    so i changed it to M307 H3 A-1 C-1 D-1 and it seems to work, cant remember why i would have it set differently?

  • Try this it worked for me for some reason.
    M307 H7 A-1 C-1 D-1 ;
    M558 P5 X0 Y0 Z1 H9 F200 T6000

Log in to reply