Probe retract with every G30 after update



  • I just updated my Duet Wifi that I am using on my Kossel Pro from 1.18.1 to 1.21, and now every time that I run a G30 command it retracts the probe. This is causing some serious problems since I am manually deploying the probe, so when I run Auto Delta Calibration it probes once, retracts the probe, and then all the future G30 commands fail. I tested manually running G30 P0 X-73.6 Y-42.5 Z-99999 and even then it retracted the probe after triggering on the bed. Anyone know why it is doing this? And how to fix it?

    Here is my config.g:
    ; Think3DPrint3D configuration file for Mini Kossel for testing Duet WiFi

    ; Communication and general
    M111 S0 ; Debug off
    M550 Kossel ; Machine name and Netbios name (can be anything you like)
    M551 Preprap ; Machine password (used for FTP)
    ;*** If you have more than one Duet on your network, they must all have different MAC addresses, so change the last digits
    M540 P0xBE:0xEF:0xDE:0xAD:0xFE:0xED ; MAC Address
    ;*** Wifi Networking
    M552 S1 ; Enable WiFi. Disabled for setup and testing. Enable once set up on your network.

    M555 P2 ; Set output to look like Marlin
    M575 P1 B57600 S1 ; Comms parameters for PanelDue

    G21 ; Work in millimetres
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    ; Axis and motor configuration
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S0 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S0 ; Drive 3 goes forwards
    ;M569 P4 S1 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    M665 R153.289 L300.0 B127.0 H265.913 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0.24 Y-0.31 Z0.08 ; put your endstop adjustments here, or let auto calibration find them
    M350 X16 Y16 E16 I1 ; Set 16x microstepping with interpolation
    M92 X160 Y160 Z160 ; Set axis steps/mm. For 1.8 degree motors on Kossel pro steps/mm = 80. For 0.9 degree motors steps/mm = 160.
    M906 X1500 Y1500 Z1500 E1000 I20 ; Set motor currents (mA) and set idle current to 20%
    M201 X1000 Y1000 Z1000 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200 ; Maximum instant speed changes mm/minute

    ; Thermistors
    M305 P0 T100000 B4267 R4700 ; Put your own H and/or L values here to set the bed thermistor ADC correction
    M305 P1 T100000 B4267 R4700 ; Put your own H and/or L values here to set the first nozzle thermistor ADC correction
    ; M305 P2 T100000 B3974 R4700 ; Put your own H and/or L values here to set the second nozzle thermistor ADC correction
    M570 S180 ; Hot end may be a little slow to heat up so allow it 180 seconds

    ; Fans
    M106 P1 H-1 ; disable thermostatic mode for fan 1

    ; Tool definitions
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 S0 R0 ; Set tool 0 operating and standby temperatures
    ;*** If you have a single-nozzle build, comment the next 2 lines
    ; M563 P1 D1 H2 ; Define tool 1
    ; G10 P1 S0 R0 ; Set tool 1 operating and standby temperatures
    M92 E92.4 ; Set extruder steps per mm. This is half of what it was with the Brainwave board, since it is only 16x micro here.

    ; PID constants
    M307 H0 A182.7 C680.2 D11 B0 ; Heated bed constants.
    M307 H1 A780.8 C229.8 D4.5 B0 ; Hot end constants.

    ; Z probe and compensation definition
    ;*** If you have a switch instead of an IR probe, change P1 to P4 in the following M558 command
    M558 P4 X0 Y0 Z0 H2 I0 ; Z probe is a switch and is not used for axis homing.
    G31 P500 X0 Y0 Z1 ; Set the zprobe height

    ;*** If you are using axis compensation, put the figures in the following command
    M556 S78 X0 Y0 Z0 ; Axis compensation here

    M208 S1 Z-0.2 ; set minimum Z
    ;
    T0 ; select first hot end

    Here is my bed.g:
    ; Auto calibration routine for delta printers
    ; Before running this, you should have set up your zprobe Z offset to suit your build, in the G31 command in config.g.

    M561 ; clear any bed transform, otherwise homing may be at the wrong height
    G31 X0 Y0 ; don't want any probe offset for this
    G28 ; home the printer

    ;*** Remove the following line if your Z probe does not need to be deployed
    ;M98 Pdeployprobe.g ; deploy the mechanical Z probe

    ; The first time the mechanical probe is used after deployment, it gives slightly different results.
    ; So do an extra dummy probe here. The value stored gets overwritten later. You can remove this if you use an IR probe.
    G30 P0 X0 Y0 Z-99999

    ; Probe the bed and do 6- or 7-factor auto calibration
    G30 P0 X-73.6 Y-42.5 Z-99999 ; X tower
    G30 P1 X0 Y-85 Z-99999 ; between X and Y towers
    G30 P2 X73.6 Y-42.5 Z-99999 ; Y tower
    G30 P3 X73.6 Y20 Z-99999 ; between Y and Z towers
    G30 P4 X0 Y67 Z-99999 ; Z tower
    G30 P5 X-73.6 Y20 Z-99999 ; between Z and X towers
    G30 P6 X-36.8 Y-21.25 Z-99999 ; half way to X tower
    G30 P7 X36.8 Y-21.25 Z-99999 ; half way to Y tower
    G30 P8 X0 Y42.5 Z-99999 ; half way to Z tower
    G30 P9 X0 Y0 Z-99999 S6 ; centre, and auto-calibrate 6 factors

    ;*** Remove the following line if your Z probe does not need to be retracted
    ;M98 Pretractprobe.g ; retract the mechanical Z probe
    M402

    ;G1 X0 Y0 Z150 F15000 ; get the head out of the way of the bed


  • administrators

    Use M401 to deploy the probe at the start of your bed.g file (and M402 to retract it at the end, which you are already doing). Then it won't run the deploy/retract cycle on every G30 move in bed.g.



  • That worked. Thanks!


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.