M122 No expansion board driver displayed



  • Hello, I encountered a problem .
    I plugged in my Duex5 and I found that the driver on the expansion board is not work, and I used M122 firmware diagnostics to check the problems.
    But here's the result.

    M122
    === Diagnostics ===
    Used output buffers: 3 of 32 (10 max)
    === Platform ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 1.21 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSN-6J1FG-3SS6J-9APVD
    Static ram used: 16152
    Dynamic ram used: 100944
    Recycled dynamic ram: 1688
    Stack ram used: 1224 current, 4456 maximum
    Never used ram: 7832
    Last reset 00:00:16 ago, cause: software
    Last software reset at 2018-08-29 11:35, reason: User, spinning module GCodes, available RAM 7760 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000, CFSR 0x00000000, ICSR 0x0441f000, BFAR 0xe000ed38, SP 0xffffffff
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms
    MCU temperature: min 35.0, current 35.2, max 35.6
    Supply voltage: min 24.3, current 24.4, max 24.6, under voltage events: 0, over voltage events: 0
    Driver 0: temperature-shutdown! short-to-ground standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2018-08-29 11:36:06
    Slowest main loop (seconds): 0.014118; fastest: 0.000046
    === Move ===
    MaxReps: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 2 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Responder states: HTTP(1) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.21RC4(08b3)
      WiFi MAC address 60:01:94:73:52:ce
      WiFi Vcc 3.35, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 17680
      WiFi IP address 192.168.31.121
      WiFi signal strength -52dBm, reconnections 0, sleep mode modem
      Socket states: 2 0 0 0 0 0 0 0
      === Expansion ===

    There's no expansion board and driver's information shown on the report,
    what should I do?

    Regard, Hex Design.Ltd

    // By the way , how can I turn off the error message ?
    // I know my drivers 0 are burned : (
    //Error: short-to-ground on drivers 0
    Error: over temperature shutdown on drivers 0
    Thanks!


  • administrators

    It sounds like the DueX5 is not being detected at power up. You can verify this by sending M115 to get the electronics string. It should return "Duet WiFi 1.xx + DueX5". If the "+ DueX5" bit is missing, then it hasn't been detected.

    If it consistently fails to detect the DueX5 when you power the Duet down and up again, check that the 50-pin ribbon cable is plugged in securely at both ends, and that you have a short thick ground wire between the ground terminals of the VIN terminal blocks of the Due and X5 as described in the wiring instructions. If that all checks out OK, ask your supplier to replace the DueX5+ribbon cable under warranty.



  • I tried to used arg 17 power cable with only 15 cm , but still doesn't work.
    But the servo channel on the duex5 can be used with no problem


  • administrators

    The servo channel doesn't depend on the Duet recognising the DueX5. I suspect your DueX5 is faulty, or possibly the cable. Can you post a photo of how you have connected the Duet and DueX5 together?



  • 0_1535723663554_IMG_0002.JPG


  • administrators

    That's not ideal because the wire joining the ground sides of the VIN terminal blocks is longer than ideal. However, although that could cause problems with communication between the two when the stepper motors are running, it doesn't explain why the DueX is not recognised by the Duet at startup. Please ask for your DueX5+cable to be replaced.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.