Installing firmware to Duet 2



  • I have a new Duet 2. I put Duet2CombinedFirmware.bin on it and had some issues. I think the SD has old iap files. I noticed that the 2.01 release did not have iap files to download. Should I download them from Release 2.0? And which one do I download - iap, iap4e, or iap4s? We don't need RepRapFirmware.bin right?



  • This is the error I get in pronterface. (I have the Release 2.0 iap4e installed on the SD in the sys folder).

    M115
    SENDING:M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.01beta3(RTOS) ELECTRONICS: Duet WiFi 1.02 or later + DueX5 FIRMWARE_DATE: 2018-07-25b1

    M997 S0
    SENDING:M997 S0
    [ERROR] Can't read from printer (disconnected?) (OS Error 6): Device not configured

    And if I rename Duet2CombinedFirmware.bin to DuetWiFiFirmware.bin, I get this error
    M997: Firmware binary "Duet2CombinedFirmware.bin" not found



  • Fixed it. I Set up wifi via Terminal on Mac (following the online instructions) and uploaded a new config.g file. The factory config.g file had been on the SD card, so I uploaded my own (which I had thought I did earlier but apparently didn't). Then it worked fine.


  • administrators

    I'm glad you got it working.

    For the Duet2 WiFi/Ethernet you need iap4e.bin (the 4e bit relates to the ATSAM4E main processor). The version from release 2.0 is current. You don't need RepRapFirmware.bin, that's the main firmware for the legacy Duets.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.