Configuration for custom filament multiplexer



  • Hi!

    I'm also working on a filament multiplexer, which looks like this one:

    https://www.kickstarter.com/projects/704208956/selectra-multi-material-system-for-your-3d-printer/description

    In my case, I have only 1 motor; filament selection is done using small clutchs.

    I'm now trying to configure RRF to control it. First, I need to define a new axis to control the loading motor. This axis has not endstop, and does not need to be homed. How do I do that? I could define it as an additional extruder, but I don't see how to use it (AFAIK I would need to assign a tool to each extruder, which is not what I want).

    Thanks for you help.


  • administrators

    You can use a G92 command to pretend that your additional axis has been homed.



  • Ok! So I can use whatever axis I want (UVWABC)?


  • administrators

    @fma said in Configuration for custom filament multiplexer:

    Ok! So I can use whatever axis I want (UVWABC)?

    Yes.



  • Ok, my first tests show that I have too much friction in my filament loading system, even with the clutch disengaged.

    A solution I would like to test is use the loading motor to help pushing the filament. Is there a way to duplicate a geometry axis to an extruder axis?


  • administrators

    You can use M584 to assign an extruder drive number as well as an axis to the stepper driver during loading.



  • I tried to change:

    M584 X0 Y1 Z2 U6 E5
    

    to:

    M584 X0 Y1 Z2 E5:6
    

    and all other config sections referring to U, but it does not work: when I extrude, axis 6 does not turn. What do I miss?


  • administrators

    To extrude using more than one extruder, the current tool must be configured to use both extruders. Then you must either set the mix ratio, or you must use multiple E values in the G1 command, e.g. G1 E10:10.



  • Got it! I enabled mixing ratio, and it works fine.

    Thanks.



  • The strange thing is I can't reach the same speed when I drive both motors (either with E10:10 or with mixing ratio) than when I drive one or the other...

    My config is:

    M584 X0 Y1 Z2 E5:6          ; Remap axes
    M350 X16 Y16 Z16 E16:16 I1  ; Configure microstepping with interpolation
    
    M92 X66.667 Y66.667 Z1417.323 E530:128  ; Set steps per mm
    M203 X30000 Y30000 Z1200 E3600:3600     ; Set maximum speeds (mm/min)
    M201 X1000 Y1000 Z100 E3000:3000        ; Set accelerations (mm/s^2)
    M566 X900 Y900 Z60 E600:600             ; Set maximum instantaneous speed changes (mm/min)
    M906 X1750 Y1750 Z1750 E750:1300 I30    ; Set motor currents (mA) and motor idle factor in per cent
    
    M563 P0 D0:1 H3 F2  ; Define tool 0 using Drive 0, Heater 3 and Fan 2
    M568 P0 S1          ; Enable mixing for tool 0
    M567 P0 E1:1        : Set mixing ratio for tool 0
    

    Any idea why?


  • administrators

    I think you will need to double the F parameter in the G1 command if it is an extrusion-only move, because F is assumed to give the total extrusion rate required.



  • Ok, I understand. I will change the steps/mm instead.


Log in to reply