Steps per mm - Mendel [solved]



  • Currently trying to calibrate a Mendel with a Duet 0.6.

    I've counted the teeth on the y axis and there are 18. I'm presuming it runs the standard 2mm pitch belt. I make that 88.888 steps per mm.

    (16*(360/1.8))/(18*2) = 88.88888888888889

    I set the bed position to y=20 and drive it to y=200 expecting to see 180mm of movement. It is more like 183.5mm. Out of interest I decide to assume I've counted teeth wrong and check 19 teeth:

    (16*(360/1.8))/(19*2) = 84.21052631578948

    ...and check what I estimate would be the correct number of steps per mm:
    (88.888/183.5) * 180 = 87.19337329700272

    Somethings is not adding up here have I missed something?

    I'm running a duet v0.6 with a shield and the critical config is as follows:

    M92 X88.888 Y88.888 Z4000 E653:651:644 ; Set steps per mm
    M566 X200 Y200 Z30 E20:20:20 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000 Y9000 Z100 E3600:3600:3600 ; Set maximum speeds (mm/min)
    M201 X500 Y500 Z15 E500:500:500 ; Set accelerations (mm/s^2)
    M906 X800 Y1000 Z800 E800:800:800 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout
    M305 X16 Y16 Z16 E16:16:16 I1 ; Set microstepping to 16.



  • Ok, just looked at my Ormerod and I was using:

    M92 X87.489 Y87.489

    Tried that in the Mendel and it works fine. Why the difference between calculated and actual?

    Edit: I have no idea where I got the figures for the Ormerod. I'm assuming I've made a silly mistake somewhere so am off for a brew before continuing!


  • administrators

    The Ormerod uses MXL belts, which have a different tooth pitch compared with GT2.



  • Groan. Thought it's be something simple.

    Thanks.

    Edit: Imperial. Figures....



  • ...and all is well:

    (16*(360/1.8))/(18*(0.08 * 25.4)) = 87.48906386701663


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.