Christmas present for Duet 06 and 085 users

  • administrators

    Santa has produced a RepRapFirmware 1.23 binary for Duet 06 and 085 users, based on the 2.02 firmware source, and snuck it into my github at His elves have tested the parts that were most at risk of being broken, and have checked it with DWC 1.22.6. However, as his toy factory no longer makes 3D printers controlled by older Duets, he hasn't been able to do a test print. So please try it out very carefully, and be generous with the mince pies tonight even if something doesn't work properly!

  • Cheers. I'll get it loaded and running soon. Maybe this evening.

    Edit: ...& Yuletide greetings to you.

  • Works for me, flashed on a 0.8.5 and using the 2.0.0 RC2 DWC.

    Printed a small print and it seems to work just fine.


  • Since upgrade to FW 1.23 on a 0.8.5 I can no longer upload to the printer via Slic3r PE. I guess this is a ftp upload.

    I have not changed my config, only upgraded the firmware and continued happy printing.

  • Moderator

    @fotomas What version of Slic3r PE? Does the gcode you're uploading have a space in it? There was an issue with that which was fixed in the latest slic3r version.

    It doesn't use FTP as far as I know, not that that matters.

    Do you get an error message at all?

  • @fotomas: Slic3r PE uses the same HTTP API as DWC.
    Does uploading via DWC still work for you?

  • I do not know what happened, but it all works now.

    I have tried several times with restart of both printer and PC in between. Maybe it comes back.
    When upload from slicer failed I still could upload from DWC.

    No errors, except within Slic3r when trying to upload.

    I have installed latest DWC but I am not using it. I had failures without connecting with the DWC to the Duet since bootup of the Duet. So I do not thing the new DWC is the cause of this.

    I will post again if this problem occurs again.

Log in to reply