Issues with motors..... Don't move



  • David,

    I have just had exactly the same failure mode. Duet Wifi, Firmware 2.02, board V1.03 from Filastruder.

    I changed the E0 motor to a 0.9 degree E3D, literally an unplug ( while off ) and re-plug. Changed e-steps in config.g, and bang! E0 fails to ground. I since tried the motor and cable on an old MKS gen L and it works fine btw.

    Measuring resistance across GND and motor outputs show a dead short, same to +VIN.

    Other motors refuse to work, but otherwise all other functions are ok ( heaters, endstops, and IR sensor detection ).

    This board was only soak tested on the machine I was modifying cycling X Y Z for 10 - 12 hours on Saturday after being in storage for since new ( March last year ).

    Ideas ?

    Keith


  • administrators

    I tested the board from @peirof. The blown stepper driver was messing up the SPI control signals to the other drivers. When I removed the blown driver, the others worked.



  • Hi....

    I undestand.... the board can be reused. No?

    I will have to change asignaments of drivers to stepper motors?... or for a 3d Scanner?... or with Duet x5?

    What stepper has down?.. and posible causes?

    what we do? (for sending, if is reusable)

    Thanks #dc42



  • Looks like the solder reflow station is going to get a workout .....

    I have 5 Duet wifi and this is the first faulty one. It's a shame it blew up so soon after commissioning though.



  • @dc42

    David, I have desoldered the E0 ( drive 3 ) TMC 2660 now, and there are blown tracks underneath the chip.

    I have made sure there are no shorts ( microscope ), but the firmware is still reporting :

    Error: short-to-ground reported by driver(s) 3
    Error: over temperature shutdown reported by driver(s) 3

    Is this expected when E0 driver chip not connected to SPI ? How do I get rid of the warnings / errors reported for this driver only ?

    Otherwise X,Y,Z and E1 functionality has been restored.

    Keith


  • administrators

    A missing driver will be read as all status bits set, including over temperature warning, over temperature error, and short to ground. Until you fit a new driver, you can use the R-1 parameter of the M569 command for that driver to suppress them.



  • @dc42

    Thanks David. Board is too damaged (I think) to refit another driver.

    I have got it all reinstalled with the config changes you proposed, and intend to use as a single extruder system.

    I just need to set the config for heater1, thermocouple 1, extruder 2, and tool 0 so that I dont need to change gcode .

    Keith


  • administrators

    @tkward, you can stick with your existing connections and config, except connect the extruder motor to E1 instead of E0, and put this line in config.g early on before any M350 and M906 commands:

    M584 X0 Y1 Z2 E4



  • @dc42 said in Issues with motors..... Don't move:

    ommand for that driver to suppress them

    In my faulty Duet.... i can do as TKWARD.... Desolder faulty driver...Suppress that driver.... and remap another driver to this axis... In this moment, i only use 3(towers) + 1 Extruder. And Duet has 5 as default.

    Can do this?

    Or..... Attach a Duet X2, and remap drivers



  • @dc42

    Thanks David. I got it running fine 🙂

    Im just dealing with retraction issues right now. I have 2 mechanically identical corexy machines, both with Duets.

    The older one is a dual bowden system with E3D Titans and a chimera hotend. Config is perfect. Firmware is V1.20.

    I copied the config to this new machine, which is a direct drive Titan and E3D, and at first glance seemed to be fine. Mechanical tweaking got things sorted.

    I obviously changed retraction and pressure advance values from from 6.5mm and PA of 0.2, but i am getting corner blobs and just unexplained issues surface issues even at very low speeds ( 20 mm/sec upwards ). I have changed the hotend, the motor ( from 0.9 deg back to 1.8, and back again, different PLA ).

    Frustrated beyond belief, but not beaten........yet.



  • @dc42 hi there i know this is a older post but i still hope you can help me 🙂 i have the same problem as in i cant get my steppers to home but i sent the comands and they moved my motors 😕 i am very confused!
    Axis and motor configuration
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M574 X2 Y2 Z2 S1 ; set endstop configuration (all endstops at high end, active high)
    ;*** The homed height is deliberately set too high in the following - you will adjust it during calibration
    M665 R105.6 L215.0 B85 H250 ; set delta radius, diagonal rod length, printable radius and homed height
    M666 X0 Y0 Z0 ; put your endstop adjustments here, or let auto calibration find them
    M350 X16 Y16 Z16 E16:16 I1 ; Set 16x microstepping with interpolation
    M92 X80 Y80 Z400 ; Set axis steps/mm
    M906 X1000 Y1000 Z100 E750 I60 ; Set motor currents (mA) and increase idle current to 60%
    M201 X3000 Y3000 Z100 E1000 ; Accelerations (mm/s^2)
    M203 X20000 Y20000 Z20000 E3600 ; Maximum speeds (mm/min)
    M566 X1200 Y1200 Z1200 E1200
    thank you for any advice



  • @jobesynoob1234 ooops forgot to say my motors are off my cr-10s with cables 🙂


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.