Newb needing help diagnosing Duet 2 Maestro..



  • So I got a M3D Promega Printer. An unproven platform to say the least. I'm fairly new to 3D printing, having only owned a M3D Micro printer in the past. When I got the Promega, I got all the networking sorted and had Web access to the Duet 2 Maestro. I went through the calibration of X,Y,Z. Temperature controls all worked for the bed and hotend. I could increase, decrease, and stop the heaters without issue. Extruders were extruding.

    Now I'm ready to print my first model, a test print of course. A rook file that was included on the microSD provided by M3D. The first layer (raft) goes down clean and looks good. PLA. 60C Bed, 210C Nozzle. Other specs: CoreXY. The below is what I am running as of today, but when i tried the prints it was whatever shipped as of Dec2018. So it also should have been fairly current.
    Firmware Name: RepRapFirmware for Duet 2 Maestro
    Firmware Electronics: Duet Maestro 1.0
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    Web Interface Version: 1.22.6
    Web Interface by Christian Hammacher
    Licensed under the terms of the GPL v3

    Once that first layer was complete and the second layer was about to start, I start getting repeated "Warning: VIN over-voltage event (##.#V) The voltage numbers jumped around 24v to 36v. (Console log file attached). The led light on the print head started strobing, as did LEDs on the Duet. (Youtube Link).

    I tried again with the same results. I tried a new file that i downloaded from the internet, Benchy, sliced it in Cura. Went to print it. Same result.

    After the third attempt printing and getting the same results each time; the heated bed stopped regulating itself and the temp would rise until I turned off the machine. I would select "Off", or "Standby", set a particular temperature for the bed heater as I would previously, but it would just keep climbing. I ended up disconnecting the bed heater from the control board so that I could continue troubleshooting the printer itself without the heated bed, fire hazard to worry about. The Nozzle temps still function properly, the X,Y,Z movements all still work. I tried updating all the firmwares I could but no joy. I get a heightmap.csv not found issue now and that is about as far as I can get with calibration.

    I'm just looking for some guidance because I've not gotten any help at all from M3D. I'm hoping someone can help out in the community. Thank you in advance for trying.

    Questions might include..
    How do I know if my thermostat is bad for the heated bed? How do I fix the Heighhtmap.csv error I keep getting? Is there a troubleshooting process I should start with or a reload of the board itself?

    0_1548100432750_console (1).txt



  • I would stop trying to print with that machine until you can get the power supply replaced by M3D. 36v risks damaging your electronics or worse.


  • administrators

    The problem may be that something (e.g. an endstop) is overloading the 3.3 rail on the Duet. That 3.3V supply is used as the voltage reference when measuring VIN, so if something is dragging it down then you will get abnormally high readings for the VIN voltage. But it could also be that the PSU is faulty and is genuinely putting out 36V some of the time.

    Does the printer behave itself if you don't turn the bed heater on? If so, that suggests that the bed heater is overloading the PSU. That could be due to a short in the bed heater or the bed heater wiring, or a faulty PSU.



  • I have the bed heater disconnected completely. For the most part things appear to work, but i'm not getting very far so it is hard to say. I tested voltage with a volt meter during the last print attempt. This was done at the PSU. I got a steady 24v while the printer attempted to print the file. only .2v fluctuation up or down from 24v. After that is when i disconnected the bed from the board. I kept getting heightmap.csv not found even after running bed meshing. I couldn't proceed past this point. So I created a heightmap.csv file and put it on the SD card hoping it would write to the file. Now it is saying it cant read from the file. Am i missing something on how to create that file? Should there be one there already? Thanks again, all.



  • @chrishuns sounds like your card might be corrupted or damaged.



  • @phaedrux
    The original one was corrupted after that third print attempt. I ended up replacing the card because i couldn't read data from it after that, and it was a cheap card to begin with. I had a backup of the original SD contents from day 1. I copied the contents of the directories to a freshly formatted (FAT32) 32GB drive. The web interface launches and I can see and edit the files from the Duet Web UI.



  • @dc42, You mentioned something on the 3.3v railpossibly overloading it. What things would i look for on that bus or rail? any particular sensors that may be plugged in there? any testing I can do to check the voltage of that rail? should it stay a steady 3.3v at all times? I can check if I know at what point on the board to look at.


  • administrators

    The "height map not found" message normally means that you are trying to load a height map using G29 S1, but you have not yet used G29 S0 (or just G29) to probe the bed and generate the height map. [Edit: or if you did, the probing failed, in which case it will have produced an error message.]

    You can pick up 3.3V on the centre pin of any endstop connector. It should be steady.



  • Thank you @dc42



  • We are sorry to hear that any of our customers had your experience. We are striving continuously to improve our processes and very recently shifted resources and processes around to make many improvements to our customer support process. If you still need help please do not hesitate to contact us through our support ticketing system by clicking Support from the PrintM3D homepage.


Log in to reply