SOLVED Duet 2 Ethernet stops mid print

  • My duet 2 is brand new, been only running it for a week. I keep having this problem where it will randomly stop mid print and the duet seems to reset (not in the same spot every time). The heaters turn off and the web interface says print completed 100% please help me

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet Ethernet 1.02 or later
    Board ID: 08DGM-917NK-F2MS4-7J1D4-3SD6N-1GTSF
    Used output buffers: 3 of 20 (13 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98132 of which 0 recycled
    Exception stack ram used: 272
    Never used ram: 7144
    Tasks: NETWORK(ready,928) HEAT(blocked,1232) MAIN(running,3844) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:00:48 ago, cause: power up
    Last software reset time unknown, reason: User, spinning module GCodes, available RAM 6192 bytes (slot 1)
    Software reset code 0x0003 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f000 BFAR 0xe000ed38 SP 0xffffffff Task 0x4e49414d
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 42.6, current 42.8, max 43.1
    Supply voltage: min 12.4, current 12.4, max 12.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 1970-01-01 00:00:00
    Cache data hit count 108928736
    Slowest loop: 1.11ms; fastest: 0.08ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 240, MinFreeDm: 240, MaxWait: 0ms, Underruns: 0, 0
    Scheduled moves: 0, completed moves: 0
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 4.45ms; fastest: 0.02ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8
    Interface state 5, link 100Mbps full duplex

  • administrators

    According to the reset data in the report, the last reset was caused by power up. So it's likely that either you had a power brownout, or your PSU cut out temporarily (perhaps because it decided it was overloaded), or your power wiring has a bad connection. Check tat the VIN terminal block screws are tight.

  • After seeing your post i decided to attach a voltmeter and watch it during one of the stalls. For some reason my atx supply had been dropping below 10volts temporarily. I bought a led power supply from amazon and it seems to have fixed the issue completely

  • administrators

    Thanks, I'll mark this as solved.

    You can use M122 after printing to see how low the VIN voltage dropped.

Log in to reply