SOLVED Error: Invalid servo index 0 in M280 command

  • Hi!

    I finally upgraded my TEVO Little Monster with the DuetWifi last night.
    I'm really surprised how well everything is working so far. 🙂

    I do however have 2 problems, that I can't seem to figure out.

    Every once in a while, I see a popup/toast in the webinterface displaying the message "Error: Invalid servo index 0 in M280 command".
    Googling this tells me it has something to do with the BLTouch sensor, but it really seems to work fine to me.

    My second issue is the auto calibration. When running this, the printer doesn't seem to know the XY offset for the BLTouch, so along the edges near my Y tower, the probe is used outside the bed. The trigger height is set correctly in config.g with "G31 P500 X0 Y20 Z0.89", but I don't see any settings for offset.
    Where can I change this?

  • administrators

    The XY coordinates on the G30 commands in bed.g are exempted from the usual limit checks. This is deliberate because on delta printers it is sometimes desirable to probe between the towers outside the normal printing limits.

    Your G31 command indicates that the bltouch is located 20mm behind the nozzle (20mm in the +Y direction). Is this correct? If so, then in the G30 commands in bed.g.with the largest Y coordinates, you will need to reduce the Y coordinate by up to 20mm.

    Regarding the error message, check the M280 commands you are using in your system files all have the correct P parameter.

  • Thanks for the response.
    The commands in bed.g were all valid.

    What I didn't notice was that Simplify3d had the same commands in the start script, without the I parameter from back when I used the board that came with my printer.

  • administrators

    I'm glad you found the cause. If you want to run auto calibration in the Simplify3D start script, just put G32 in there.

    I'll mark this as solved.

Log in to reply