BLTouch not working on Duet Wifi



  • Hello,

    I recently came around to wiring up my genuine BLTouch Smart (newest revision).
    I set it up like described in the wiki. Further down is my config.g.
    When the Duet starts up, the probe deploys and retracts a few times and then lights up solid red, but won't react to any commands (M280). With G31 it reports back a 0 in both pin positions.
    Iam completely sure I wired it up correctly, checked the continuity with a multimeter and double checked the pinouts (Black and white in the Z probe header, Brwon and Red for +5V and GND and the orange/yellow on in the Heater 7 pin).

    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 31 2019 00:55:14 GMT+0100 (Mitteleuropäische Normalzeit)

    ; General preferences
    G90 ; Send absolute coordinates...
    M83 ; ...but relative extruder moves

    M667 S1 ; Select CoreXY mode

    ; Network
    M550 P"Druckbert" ; Set machine name
    M552 S1 ; Enable network
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S1 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1 ; Configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E94.00 ; Set steps per mm
    M566 X900.00 Y900.00 Z12.00 E900.00 ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z180.00 E3600.00 ; Set maximum speeds (mm/min)
    M201 X800.00 Y800.00 Z250.00 E800.00 ; Set accelerations (mm/s^2)
    M906 X1000.00 Y1000.00 Z1000.00 E1300.00 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X300 Y300 Z300 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 S1 ; Set active high endstops

    ; Z-Probe
    M574 Z2 S2 ; Set endstops controlled by probe
    M558 P5 X0 Y0 Z1 H5 F120 T6000 ; Set Z Probe to type Switch or Digital output where Z probe connector is used. Used for z only
    G31 P50 X-25 Y38 Z1.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:285 Y15:285 S40 ; Define mesh grid

    ; Heaters
    M307 H0 B0 S1.00 ; Disable bang-bang mode for the bed heater and set PWM limit
    M307 H7 A-1 C-1 D-1 ;Disable heater 7 for BLTouch
    M305 P0 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; Set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; Set temperature limit for heater 1 to 280C

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings are not configured



  • @ordner said in BLTouch not working on Duet Wifi:

    With G31 it reports back a 0 in both pin positions.

    I'm not sure what you mean by this.

    What firmware version are you using? If you are using version 1.21 or higher you can use M558 P9 probe type which is specifically for the BLTouch.

    In your M558 command, you can remove X0 Y0 Z1 since it's no longer used.

    Have you checked config-override.g to see if your Heater pin isn't getting re-enabled? It looks like you don't have an M501 command in your config.g so wouldn;t be using config-override.g anyway.

    What commands exactly are you trying to use in deployprobe.g and retractprobe.g?

    Does the pin react if you send M401 or M402?

    Have you see this? https://duet3d.dozuki.com/Wiki/BLTouch_Troubleshooting

    Or gone through this? https://duet3d.dozuki.com/Wiki/Test_and_calibrate_the_Z_probe



  • Hey, thank you for your answer.
    Iam on the latest firmware. I set the probe type now to P9, removed the parameters in the M558 command but I'm afraid I cant find a config-override.g in my files.
    Do I need the M501 command?
    Deploy probe: M280 P7 S10
    Retract probe: M280 P7 S90
    M401 and M402 does nothing.

    I've gone through your links, thank you, but still nothing.
    I've changed my M558 to "M558 P9 F100 H5 R0.2 T6000 A5 B1"

    I also tried to cut and "uncut" the pad on its back, but it won't affect anything.

    Thank you for your patience.



  • @ordner you don't need config-override. It's usually used to save heater values are doing a PID tune. The reason I mentioned it is because the heater values that get written to it can override the command to free up the heater pin we need for the BLTouch.

    It sounds like you have a wiring problem. Double check that the wires are going to the right places. Check the wires and crimps for breaks. Check contiguity with a multimeter.



  • @phaedrux Hey, thanks for your input. As mentioned, I double and triple checked the wiring and am 100% certain that it is correct - so it was.
    I played around with all kind of values and possibilities until someone mentioned to add the I1 command in the deploy and retractprobe.g - and thats it, it works!



  • Glad you got it working.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.