Dual Extrusion Tool Changing

  • As I dial in my tool change free, pre and post macros, I had a couple basic issues that I think I can solve, but I am unsure.
    My setup is e3D chimera, CoreXY, T0 is direct-drive e3d titan, T1 is bowden e3d titan. All of my ptfe tubing is capricorn. I've mounted a purge bucket/wiper at just behind the bed the back-right corner of the machine.

    I move the extruder to the purge position, ram 4 mm at f420, retract 40mm to get the filament up into the capricorn tubing. I move it back and forth 5mm for a little cooling move to prevent reloading jamming (this part works reliably so far).
    Then the active extruder goes to standby and the other starts to heat, M116 until its heated. Then I push 40.5mm at F420. Then I move the nozzle over the lip of the purge bucket to remove the extruded filament.

    The problem comes in here: if I don't manually do a G1 E-.4 or E-1.8 (still not using firmware retraction just yet), I get crazy stringing during the move back to the part. However, if I retract before the move, I get underextrusion at the beginning of the next perimeter or ooze shield/tall brim. Is there a way to get back to the resume spot while still in tPost. I'm not seeing the G1 R1 parameter fully explained well, would that do what I want?

    At work, so when my SO plugs in my printer, I'll post the actual tFree, tPre and tPost files...

  • administrators

    G1 R2 should get you back to the position just before the T command started executing.

  • Thanks, I'll give that a try tonight.

  • I'm thinking about going back to dual extrusion. I had it working when I was on Marlin but wasn't ready to try and figure out how to get the duet working and trouble shoot multi printing. Would you be willing to share your dual config files. It would give me a head start.

  • I'll do my best to remember to upload them when I get home from work.

  • @antlestxp tpre1.g

    These are my config and tool macros. I started with the configurator, but basically have rewritten the whole file by now 🙂
    Obviously, I'm still dialing in the settings, please share if you get yours working first!

  • sweet thanks

  • Those files worked for hatchbox and amazon pla that I had loaded, but since I've tried other filaments, I just end up grinding away at the filament and printing air...

  • administrators

    @gregspruce said in Dual Extrusion Tool Changing:

    Those files worked for hatchbox and amazon pla that I had loaded, but since I've tried other filaments, I just end up grinding away at the filament and printing air...

    Extrusion temperature set too low for those filaments?

  • @dc42 Turns out I had accidentally gotten the others "working". My scripts attempted to do the purge in Tpre, when extrusion is disabled. The earlier filaments didn't form a plug sitting in the hotend, just oozed all over instead.
    Fillamentum filament has always given me issues with forming plugs, even in the Prusa MMU1 and MMU2. So in the broken macros, it was cooking and formed a plug/clog.

    I think I either need to attempt to get the purge and 50mm retract out of the hotend completely working (without grinding during the purge and forming decent tips that will re-feed later without grinding), or switch to just retracting ~5mm - which is the max for the chimera heatbreak before plugs form at the top of it. That method might be more difficult to control oozing.


Looks like your connection to Duet3D was lost, please wait while we try to reconnect.