Extruder skipping



  • @dc42 said in Extruder skipping:

    That suggests insufficient torque from the extruder motor, or just possibly a partially-blown extruder stepper driver. Which motor are you using?

    Im using a MT-1703HSM168RE which should provide 2.5kg/cm in holding torque. I could try switching to E1 instead to see if the E0 driver is the problem.

    @Edgars-Batna
    Good point. Here is the gcode file I'm using: gcode file.

    Here is the full config file as im trying the same print with E1 instead of E0:

    ; Configuration file for Duet WiFi (firmware version 1.21)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu Jan 31 2019 14:18:29 GMT+0100 (Central European Standard Time)
    
    ; General preferences
    G90                                         ; Send absolute coordinates...
    M83                                         ; ...but relative extruder moves
    M665 L360.220 R214.972 H727.362 B110.0 X-0.121 Y-0.016 Z0.000   ; Set delta radius, diagonal rod length, printable radius and homed height
    M666 X-6.661 Y-0.627 Z7.288 A0.00 B0.00                         ; Put your endstop adjustments here, or let auto calibration find them
    
    ; Network
    M552 S1                                     ; Enable network
    M586 P0 S1                                  ; Enable HTTP
    M586 P1 S0                                  ; Disable FTP
    M586 P2 S0                                  ; Disable Telnet
    
    ; Drives
    M584 X0 Y1 Z2 E4                            ; Set extruder to use E1 instead of E0
    M569 P0 S1                                  ; Drive 0 goes forwards
    M569 P1 S1                                  ; Drive 1 goes forwards
    M569 P2 S1                                  ; Drive 2 goes forwards
    M569 P3 S1                                  ; Drive 3 goes forwards
    M569 P4 S1                                  ; Drive 3 goes forwards
    M350 X16 Y16 Z16 E16 I1                     ; Configure microstepping with interpolation
    M92 X100.00 Y100.00 Z100.00 E:795          ; Set steps per mm
    M566 X1200.00 Y1200.00 Z1200.00 E600.00     ; Set maximum instantaneous speed changes (mm/min)
    M203 X18000.00 Y18000.00 Z18000.00 E3600.00 ; Set maximum speeds (mm/min)
    M201 X1000.00 Y1000.00 Z1000.00 E1000.00    ; Set accelerations (mm/s^2)
    M906 X1300.00 Y1300.00 Z1300.00 E1300.00 I30; Set motor currents (mA) and motor idle factor in per cent
    M84 S30                                     ; Set idle timeout
    
    ; Axis Limits
    M208 Z0 S1                                  ; Set minimum Z
    
    ; Endstops
    M574 X2 Y2 Z2 S1                            ; Set active high endstops
    
    ; Z-Probe
    M558 P8 R0.6 H5 F1200 T6000 A1 B1           ; Set Z probe type to effector and the dive height + speeds, and turns off bed heater since the psu doenst have enough power
    G31 P80 X0 Y0 Z-0.1                         ; Set Z probe trigger value, offset and trigger height
    M557 R100 S10                               ; Define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                            ; Disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 S"Heat bed" T101200 B4267 R4700                 ; Set thermistor + ADC parameters for heater 0
    M143 H0 S120                                ; Set temperature limit for heater 0 to 120C
    M305 P1 S"Extruder 1" T100000 B4725 C7.06e-8 R4700        ; Set thermistor + ADC parameters for heater 1
    M143 H1 S280                                ; Set temperature limit for heater 1 to 280C
    
    ; Fans
    M106 P0 S0   I0 F500 H-1                    ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H T45                    ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H T45                    ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 D0 H1                               ; Define tool 0
    G10 P0 X0 Y0 Z0                             ; Set tool 0 axis offsets
    G10 P0 R0 S0                                ; Set initial tool 0 active and standby temperatures to 0C
    
    M912 P0 S-5.8                               ; Calibrate CPU temperature
    ;M572 D0 S0.3                                ; Enable pressure advance
    M501                                        ; Load config-override
    
    


  • The problem still persists when I changed the stepper driver. I have not used the E1 driver before so I think it is unlikely that the stepper driver is faulty.

    I'm going to try and print it without the heated (if I can manage to get good adhesion) to see if the problem is too low power.


  • administrators

    Is the motor definitely skipping steps, not the hobbed shaft losing its grip on the filament?



  • The power seems to be the last hurdle together with the other fixes since I've managed to print the whole tower without extruder stepper problems. The last sections are under extruded but it was expected from the filament properties.

    I guess it means that it is time to bite the bullet and upgrade the last parts of the printer as well, but thank you all for your input and help.


Log in to reply