Fan setting ?



  • Hello,

    I'm having a problem with a fan.

    My fan in Fan0 (the one that serves to cool the material) whistles (like a light continuous beep) as soon as it is connected!

    This same fan does not whistle on another machine (Marlin).

    Its order under Duet3D is as follows: M106 P0 S0.4 I0 F500 H-1

    I connected it on Fan2 (M106 P2 S0.4 I0 F500 H-1) and it's always the same?

    I thought of lowering the HZ (Fxxx). This slightly improves this whistling, but it is still present.

    My fan is 12v, my power supply is 12V and Jumper Select is on VIN?

    An idea? Thank you !



  • @rudy2a
    It is usual to set the part cooling fan initially to be off in your configuration file, then let the slicer add the fan speed commands to the gcode file. You have S0.4 which means that the fan will run at 40% speed as soon as the machine boots. So changing it to S0.0 will turn it off.



  • @deckingman
    Super it works!
    Thanks to you...



  • The RRF config tool seems to generate these odd fan commands in config.g. It seems to be intending to set the minimum PWM setting (L parameter) but instead generating it as the S parameter.


  • administrators

    It appears to me that the configurator defaults fan 0 to running at 30% at startup. I can't see any reason for that, so I will have it changed.


Log in to reply