Duet Web Control 404 error



  • I have a Duet 2 Wi-Fi which was having some issues with G-code files failing to upload sometimes. I tried all the instructions to reformat the card correctly and I also tried a brand new card. Nothing seemed to work.

    I turned to the forums and found a post in which someone with the same firmware version as me (2.02) was able to fix their issue by doing an update to version 2.03. I followed the instructions and link provided in the post, but when i tried to use DWC to upload the .zip file i encountered some errors during the upload.

    I was afraid this may happen, but from what I had read it seemed like it would upload first, then install, so i figured there wouldn't be anything at risk if the upload failed, i could just try again.

    After several failures I called it a night and came back to it the next morning. That is when I discovered that when I try to open DWC, all i get is a screen that displays "ERROR! ERROR! ERROR! 404 - the requested file could not be found."

    I would like to be able to give you all more specifics or screenshots of the versions of firmware I currently display...but I am unable to do so given the current situation.

    What is my best course of action here in order to recover from this failure?



  • Put the Duet SD card in your PC, and replace the contents of the /www directory with the contens zip file that you'd normally upload in order to update DWC. Unzipped, of course.



  • That worked! Thank you for your help. My delta is back up and running.



  • I seem to have developed another problem. I started a print after I was able to use DWC again. The print has been running overnight and I used DWC several times to check the progress throughout the evening. Now when I try to connect to DWC again, I am getting another error "this site can't be reached. The connection was reset". My printer is still running the same job, nothing changed but the time of day, but I'm back in the boat I was before, unable to use DWC.

    Any ideas on what to try next?


  • administrators

    Is the blue LED on the WiFi module still lit, indicating that the firmware thinks it is still connected to the access point?

    If you have a PanelDue or a USB/YAT connection, you can also send M552 to check the network status.



  • The blue LED is lit, M552 shows it is connected to my network.


  • administrators

    Looks like your router is ignoring the Duet. Suggestions:

    • Send M122 from YAT and see what WiFi RSSI (signal strength) it reports
    • Send M552 S0 then M552 S1 to force it to connect again


  • I was waiting for my print to finish before trying anything. I just watched it finish and for some reason instead of the head moving upwards to the home position, it just stopped slightly above the end point and all function froze. (I printed a copy of this same G-code file before and it finished with a return to home as intended.) The system reset itself and I was able to connect to DWC again. I'm guessing this is because the connection was re-established upon reboot. Still leaves the question as to why it stopped like it did.

    I love this board, but I'm not sure whats going on with all these little oddities lately.


  • administrators

    If you think the Duet reset itself, get a M122 report out of it before you do another software reset.



  • M122 report:
    M122
    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.02(RTOS) running on Duet WiFi 1.02 or later
    Board ID: 08DGM-956GU-DJMSN-6J9FA-3S86J-TARZG
    Used output buffers: 3 of 20 (10 max)
    === RTOS ===
    Static ram: 25524
    Dynamic ram: 98620 of which 0 recycled
    Exception stack ram used: 432
    Never used ram: 6496
    Tasks: NETWORK(ready,544) HEAT(blocked,1232) MAIN(running,3788) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 02:29:51 ago, cause: software
    Last software reset at 2020-05-09 10:59, reason: Stuck in spin loop, spinning module GCodes, available RAM 6268 bytes (slot 2)
    Software reset code 0x4043 HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f80f BFAR 0xe000ed38 SP 0x20001efc Task 0x5754454e
    Stack: 00443523 00446ee6 21000000 dc000000 4153df1c 00000000 00000000 434b3217 436a1fe6 bdb81c00 4893afd1 cb295ff9 422b1a1b 00000000 476c1e00 37d33333 3f800000 60000000 411fcb61 20000010 00000004 00000000 00000004
    Error status: 8
    Free file entries: 9
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 39.6, current 42.9, max 44.6
    Supply voltage: min 12.6, current 12.9, max 13.3, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: ok, SG min/max 0/1023
    Driver 1: ok, SG min/max 0/1023
    Driver 2: ok, SG min/max 0/608
    Driver 3: ok, SG min/max 0/1023
    Driver 4: standstill, SG min/max not available
    Date/time: 2020-05-09 13:30:07
    Cache data hit count 4294967295
    Slowest loop: 342.01ms; fastest: 0.07ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0
    === Move ===
    Hiccups: 0, StepErrors: 0, LaErrors: 0, FreeDm: 121, MinFreeDm: 120, MaxWait: 509865ms, Underruns: 0, 0
    Scheduled moves: 105415, completed moves: 105385
    Bed compensation in use: none
    Bed probe heights: 0.000 0.000 0.000 0.000 0.000
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 0 is on, I-accum = 0.0
    Heater 1 is on, I-accum = 0.4
    === GCodes ===
    Segments left: 1
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is doing "G1 X13.922 Y-3.572 E25.24059" in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 15.61ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address 60:01:94:73:5b:e9
      WiFi Vcc 3.39, reset reason Turned on by main processor
      WiFi flash size 4194304, free heap 25240
      WiFi IP address 10.0.0.17
      WiFi signal strength -71dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

    EDIT: The router isn't responding to the duet again. Same as before, started a print, able to use DWC for a while, then the same error connection reset page as before.

    Upon print finish (different file this time) the printer froze again and I could not command it to do anything until I pressed the red stop button. it then reset and would go to home.

    M552 shows it is connected to the network. Cycling S0, S1 doesn't seem to do anything as it still shows connected to the network after sending S0 and after sending S1. I'm still unable to connect to DWC.

    The duet now seems to freeze up after every completed print and will not move until it reboots. What should I try next?



  • I've had a couple of short prints in which I can maintain DWC access, but anything longer than about 4 hours ends up disconnecting.

    With the short prints, the head retracts to the home position as it should at the end of a print.

    Any time a print results in a disconnect from DWC, it will still freeze at the end of the print. This is very irritating as I'm usually left with a blob of drool on the top of my print if I'm not there to intervene right when the print finishes.

    I'm really at a loss as to why loss of DWC access would result in the printer freezing up at the completion of a job.

    Any input or assistance is greatly appreciated.



  • This sounds like an issue I see sometimes. Are you on ethernet or wifi?



  • Wi-fi. My printer is in my shop in the basement, my router is on the 1st floor, maybe 10ft away from the printer's location.

    EDIT: So much for my theory on long prints being related to disconnects. I'm in the middle of a 2 hour print and I've lost DWC again.



  • I'm reaching a peak of frustration with the disconnecting issue. It seems like its happening more frequently. I'm trying to change some settings to improve the printer's accuracy and I cannot stay connected to DWC for more than five seconds at a time before getting an error message that says request time out.

    I cannot keep my printer going with an interface that behaves like this. Can anyone please help me?


  • administrators

    Which version of DWC are you using?

    The duet now seems to freeze up after every completed print and will not move until it reboots. What should I try next?

    When it freezes, are you able to connect via USB/YAT and get a M122 report?



  • Sorry for the delay, i've been sick the past couple days and hadn't made it back into the workshop.

    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    I've been able to connect via YAT when i lose DWC connection. The connection seems stable so far this morning, I haven't been disconnected yet and I've been on for about 30 minutes so far.


  • administrators

    Your WiFi and DWC versions are OK, but your main firmware version (2.02) is old. I suggest you upgrade it to 2.05.1.



  • I've just updated the duet, I will see how stable the connection remains and report back.



  • I am still experiencing disconnects (just had one). I also have network errors when trying to upload g-code files or update my config file, which causes it to disappear from the system and needs to be manually uploaded via sd card. I'm also getting several new errors in the lower right hand corner of the screen when I start up the printer and press home:
    4e7d7286-d2c2-4f09-8920-592659cb1bb8-image.png


  • Moderator

    https://duet3d.dozuki.com/Wiki/FAQ#Section_I_get_this_error_message_Error_G0_G1_insufficient_axes_homed

    Your homing files need to be updated to have S2/H2 on moves of axis that are not yet homed. This is usually for lifting the Z axis for clearance before homing X and Y. In fact, the error message is giving you the exact line causing the issue G1 Z-25 F6000 Adding H2 to that line will stop that error message.


Log in to reply