New firmware 1.19 beta 2


  • administrators

    I've just released this at https://github.com/dc42/RepRapFirmware/tree/dev/Release (look in the Edge folder for your board). See https://github.com/dc42/RepRapFirmware/blob/dev/WHATS_NEW.md for the full change information and important upgrade notes.



  • Awesome. Will try it in the morning.



  • Great news David. Today I will try to install it in my Wi-Fi Duet.
    Thanks Mr.David Dc42 😉


  • administrators

    One known bug in this release so far: the use of heater numbers 101 and 102 in the M106 command (to turn fans on if the drivers report over-temperature) isn't working.



  • I tried it late last night. Wifi connects just fine. But now my printer will not home any axis and the x and y motors will not operate. The heaters and fans work. Rolled it back to old firmware and now my printer is working.



  • Same here. Also, each reboot (e.g. M999) is a double boot. It comes up for ~15 seconds, drops and comes up again for good.
    This is not a WiFi drop, but a whole board reset, because serial connection goes out too.


  • administrators

    @vhoward and @sigxcpu, what printer geometry do you have (i.e. Cartesian, CoreXY etc.) and what type of endstop are you using? What (if anything) happens when you try to home? Does M119 report the endstop switch states correctly?

    @sigxcpu, can you run M122 when the board comes up the second time, and post the result?

    I have tested 1.19beta2 on a delta printer controlled by a Duet WiFi and on a Cartesian printer controlled by a Duet 0.8.5. I don't have a CoreXY printer to test on, but I can simulate CoreXY kinematics on my Cartesian machine.



  • Mine is a CoreXY. All end-stops are NC switches. There is some short high pitched noise when it attempts a 2nd Z home and nothing happens. The switch is already clicked when the operation starts 2nd, 3rd… times. With 1.18.1 is pulls back a little and attempts the homing. I assume it does what it says below (homez.g):

    G91                       ; relative mode
    G1 S1 Z-350 F1200               ; course home Z
    G1 Z4 F300             ; move away from the endstops
    G1 S1 Z-10                ; fine home Z
    G90
    
    

    I will run M122 after I'll attempt to upgrade again. It took a while to do that (open the back-plate of the printer to have USB access) and I'm not too keen to re-do it 🙂
    I'm pretty upset because I did two things today (fiddle with Z mechanics and upgrade the Duet) and forgot about the fiddling part, so on the first print attempt I've managed to put some huge deep scratches in my PrintBite 😞
    Another reason to avoid playing with the printer for a while. Maybe it is not my good day/week/month.


  • administrators

    Thanks. Why do you need to access the USB port? You can do the simultaneous firmware upgrade through the web interface.



  • My printer is a corexy hypercube. End stops are the Makerbot style microswitch on the little pc board made by Big Tree Tech. X and Y axis will not home and will not move at all. The Z axis will move, but will not home until x and y are homed.

    Last night when I rolled my duetwifi back to 1.18.1, I did a fresh install of the duet web control also. Seems to be fairly stable now. I have cycled my duet wifi on and off several times today, and every time it connects to my router with out a hitch. If this continues, I will not be upgrading to a new firmware. My hypercube is working great now. No need to mess with it.


  • administrators

    I've tracked down the problem with using 1.19 on a CoreXY printer. The axis factors are defaulting to 0 instead if 1. I will fix this in beta 3. Meanwhile, the workaround is to specify X and Y axis factors of 1 in your M667 command. So instead of just sending M667 S1, send M667 S1 X1 Y1.


  • administrators

    Firmware 1.19 beta 3 is now out with fixes for the following issues:

    • The default axis factors for CoreXY printers were incorrect
    • Mesh bed levelling was never enabled
    • Thermostatic control of fans based on TMC2660 temperature warnings was not working


  • HI dc42 sorry about this but i have never been able to get a stable wifi connection with the DuetWifi, i have always put it down to firmware and the hope the next version will fix the issues but now even with your latest beta releases of 1.19 its even worse. After now 7 months of ownership the board when working is fantastic the only problem is it never lasts more than a few days before i cant reconnect over wifi or the web interface drops out constantly through ajax errors. I honestly couldn't tell you how many times i have come to the machine after a couple of weeks turned it on opened the web interface and nothing to find again for the god knows how many time the port says bossac and not lpt1 and i have to re-flash the firmware. Today was the last straw after running perfectly for 9 hours over the past 2 days i switched the machine off after the print finished and everything cooled down, went to turn it on this morning and again as so many times before no connection to the web interface, hooked up my laptop and again in device manager bossac. Decided to try 1.19beta2 followed your guide and all is well for 2 mins and never managed to got connected again. I know this isn't exactly a commercial board and is always under development but it should at least work more than 15% of the time. I have now come to the conclusion that i cant trust this board for any work i need to do but hope that you can get a handle on all these issues in the future. Because honestly when it works its great just not reliable.


  • administrators

    I'm sorry you have had so much trouble. It should not be reverting to Bossa Port like that. Are you quite certain that nothing is pressing against the Erase button?



  • DC42, with the current 1.19Beta3, are the flashing instructions still the same as with the previous 1.19 versions that require the firmware and wifi to be updated simultaneously?



  • Hi dc42, nothing is pressing against the erase or reset ports like i said i always put down the ajax errors and odd firmware resets down to the firmware but over the months and update after update nothing has ever improved, it just seems to get worse. And as an early purchaser number 62 i think i never expected things to be perfect, but some stability would have been nice, the 2 Duet 0.8.5 i have i haven't updated in a long long time but work fine ( well except one with a fan issue but its fine ).


  • administrators

    So is the main problems that the port reverts to the Bossac port, which will have the side effect of making it impossible to connect with the board over WiFi? If so then I'm happy to authorise a replacement board, because that should not be happening. However, if this mostly occurs when the printer has not been used for a while and you live in a country with high humidity, then this problem might be caused by condensation, and I may be able to suggest a modification you could try.


  • administrators

    @Sniffle:

    DC42, with the current 1.19Beta3, are the flashing instructions still the same as with the previous 1.19 versions that require the firmware and wifi to be updated simultaneously?

    Yes if you are upgrading from firmware 1.19alpha or earlier. If you are already running 1.19beta 1 or 2 then you just need to update the main firmware.



  • I upgraded to 1.19beta3. Now it does not connect over a web connection. In fact it does not advertise its web service at all.
    (I'm an IT guy…)
    Do I need to revert to the 1.18 i was running or is there a way to correct this? How would I roll it back to the previous firmwares?


  • administrators

    You need to set up access to your router different!y. There is a link to the instructions in the upgrade notes, but here it is for your convenience: https://duet3d.com/wiki/DuetWiFiFirmware_1.19_alpha.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.