Complete download needed for new installation… confused!

  • Well, I'm a ham fisted sort who has exceeded my capabilities, apparently. Since the Duet has gotten so much great attention on the Nimble forums, I finally bought the wifi board and a panel Due because of USB /computer problems between printers and computer/S3d. Anyway. I broke the pre-flashed Duet SD card. Yep. No hope there. And I have been trying to get myself up and running without success. I can get a Bossa 1.8 port connection, but there it ends. .bin files don't engage. duet web doesn't load, Duet 1.19 sits there mocking me … I'm a mess. Any recommendations?

  • administrators

    You don't need to re-flash the firmware if the SD card is broken, unless you have pressed the Erase button. You just need to get a new SD card and put the right files on it.

    When you connect the Duet via USB to a Windows computer, what shows up under Device Manager -> Ports (COM and LPT)?

  • Bossa on Com10. Unfortunately, I did press the erase button following one of the many paths that can be found online. I have added the right files, I think, to a new SD card, but get no farther than the Bossa port. Can't open Bossa (if that is an option?) and a YAT port just disappears as soon as I try to launch it.
    \THank You for your help David!

  • administrators

    What happens when you load Bossa 1.8 and try to program the DuetWiFiFirmware.bin file? You need to check in the Erase All, Lock and Boot From Flash boxes first.

  • It took a while to find Bossa but I have a successful write of the 1.18 firmware over the serial port shown for Bossa. Next?

  • I can open a YAT terminal and communicate with the now listed Duet port but haven't added any other firmware yet. The M552 SO command yields an <ok>response. Where should the RepRap firmware and/or wifi firmware be flashed - the files are on the SD card. Can't access Duet web control through Chrome - get a 404 message.
    Sorry to be so dense but I do try to understand what I'm doing… or need to do.</ok>

  • administrators

    When you restart the Duet, Device manager should show in the Ports section that you have Duet electronics connected. Does it? If so then you can connect to it using Pronterface.

    It's going to be easier in the long term if you upgrade to 1.19 firmware. You can find the files at Extract the contents of the file to /www on your SD card. Copy DuetWiFiFirmware.bin and DuetWiFiServer.bin to /sys on your SD card, removing the -1.19 suffix from the name. Also set up a macro to program your access point details, as described at When you have done all that, send M997 S0:1 from Pronterface to upgrade. The Duet will disconnect when it upgrades the main firmware, but after less than a minute the Duet port should appear again and you can reconnect.

  • Hi David, Sorry for disappearing there - home stuff. Anyway, yes I do have Duet connected. I have also discovered an unfortunate .bin file association that seems to be preventing the wifi and server files from being installed. When I run M997 SO:1 it says that it can't find the .bin files though they are in both a temp C file and on the new duet SD card. Is there a file association I can use that will get me back on track?
    But, duet port exists and pronterface can connect so a little bit of progress….

  • administrators

    • Files DuetWiFiFirmware.bin and DuetWiFiServer.bin must both be in the /sys folder of the SD card

    • They need to have exactly those names. So if the file was called e.g. DuetWiFiFirmware-1.19.bin when you downloaded it, you must rename it to DuetWiFiFirmware.bin on the SD card. Similarly for the other file.

    • If you remove and re-insert the SD card while the Duet is already running, you just either restart the Duet, or remount the SD card by sending M21. If the firmware you are running is older than 1.18.2, you must restart the Duet.

    HTH David

  • The files are both named correctly and in that folder on the SD card. However, Windows 10 is translating or opening them during the download from the web into something other than a .bin file. It won't allow me to download without a file association of one sort or another. I have tried a sam-ba association, but that doesn't work. I can't find a way to have no file association at all. Revert defaults perhaps?

  • administrators

    Windows shouldn't require a file association fo you to download a file. However, it has an annoying habit of not displaying the file extension for "known file types". You can suppress that in the options in File Explorer.

    If you go to and click on the links to the .bin files, you should get a "Save as" prompt.

  • Progress?
    This what Pronterface tells me:
    SENDING:M997 SO:1
    Trying to connect at 460800 baud:
    Erasing 244400 bytes…
    Uploading file...
    5% complete
    10% complete
    15% complete
    20% complete
    25% complete
    30% complete
    35% complete
    40% complete
    45% complete
    50% complete
    55% complete
    60% complete
    65% complete
    70% complete
    75% complete
    80% complete
    85% complete
    90% complete
    95% complete
    Upload successful
    [ERROR] Can't read from printer (disconnected?) (SerialException): call to ClearCommError failed
    [ERROR] Can't write to printer (disconnected?) (SerialException): WriteFile failed

  • administrators

    That's normal. It's uploaded the WiFi firmware successfully and then closes the USB port while it upgraded the main firmware. Assuming you left it.powered up for a minute or so to complete the upgrade, you should be able to reconnect.

  • OK. I have redone it all and those files are installed, Pronterface is connected and the SDHC card is mounted.
    I remain lost past that.
    Where should I install RepRap Firmware 1.19? Were all files that exist on the SD card uploaded, i.e., /www folder and /macro folder? And I'm still nowhere with Duet Web Control.
    I'm dense with ignorance and you must be shaking your head dealing with a NOOB such as I. I don't know why this is so difficult for me - I've managed to blunder my way through Arduino (for RAMPS), Smoothieboard setups and a couple of others along the way, but this is somehow wicked confusing to me.
    I truly appreciate your time and efforts on my behalf!


  • administrators

    When you send M115, what firmware version does it report? If it reports version 1.19, that's good. What you need to do next is send M552 S1 to enable WiFi networking.

  • This is the message: FIRMWARE_VERSION: 1.19 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-08-14
    ok T B:2000.0 /0.0

    M552 S1
    SENDING:M552 S1
    WiFi module started
    WiFi reported error: no known networks found

    So, when configuring, do I use and "preprap"? Or my own router?

  • administrators

    So you need to use M587 to tell it what SSID to connect to and what password to use. Doing this from Pronterface won't work because any lowercase characters in your password will be converted to uppercase. You can either use a terminal emulator instead (I use YAT under Windows), or set up a macro file to do it as described in the instructions for upgrading to firmware 1.19.

  • So close!
    This from the duet web control all connected and working:
    Firmware Name: RepRapFirmware for Duet WiFi
    Firmware Electronics: Duet WiFi 1.0
    Firmware Version: 1.19 (2017-08-14)
    WiFi Server Version: 1.19
    Web Interface Version: 1.19

    I cannot find config.g to modify for auto connect. I have sent motion and homing macros with appropriate settings. Tried to do necessary 1.19 updates and those look good, but why no config.g? Should upload RepRap firmware 1.19? still no machine movement or anything, but probably need to activate tools?

    So far, one step per message. As ever, thank you!

  • administrators

    You are already running RepRapFirmware 1.19. Go to the Settings page of Duet Web Control, then the System Files Editor tab, there you will find the config.g file and you can edit it. If for any reason isn't there, go to to generate a new one. You can upload just config.g or the whole zip file generated by configtool through the Settings General tab of Duet Web Control.

  • Finally. Although I've yet to print (having motion and homing difficulties) I can interact with the machine with consistency on both WiFi and PanelDue. I've got heat everywhere I need it and the extruder is working accurately from my previous steps/mm config. I release you to roam freely in new vistas and stop coddling me through my incompetencies.
    Thank you very much, David. The Duet seems great and I have no doubt I will get it figured out sometime this week. It is better for me to struggle a while right now so I can learn it more effectively.


  • Good day . please tell me .I accidentally pressed the ERASE button and flew all the firmware reading on the website I realized that you need to install Bossa . I installed it but do not understand which files and where to download please tell me .DuetWiFi

  • Good day . please tell me .I accidentally pressed the ERASE button and flew all the firmware reading on the website I realized that you need to install Bossa . I installed it but do not understand which files and where to download please tell me

  • administrators

    All you need to know should be at If there is anything there that you don't understand, feel free to ask again.

  • Good day . The link you advised . I did SC was listed on the page of the link . but that does not work out . can you write the process how to do it and what firmware need and do I need a flash drive for flashing process.

  • administrators

    I have written the process, it's on the page I linked to. What didn't work for you? What do you mean by "SC" ?

    You don't need a flash drive to install new firmware, you need either the SAM-BA program or the Bossa program in your PC as described on that page, and a USB cable between your PC and the Duet.

Log in to reply