Cant get my duetwifi to work after new FW.


  • administrators

    Please try the just-released firmware 1.20 (both main and WiFi). Note the correct installation order as detailed on the release page of GitHub. If you still can't get it working, you can revert to older firmware.



  • @dc42:

    Please try the just-released firmware 1.20 (both main and WiFi). Note the correct installation order as detailed on the release page of GitHub. If you still can't get it working, you can revert to older firmware.

    Have now try this out, but sorry to say its the same… It remember my network but no IP number... This cant be FW issue at all i have try out all
    options now. OR do i miss someting?...

    SENDING:M587
    Remembered networks:
    gixxerturbo IP=0.0.0.0 GW=0.0.0.0 NM=0.0.0.0

    SENDING:M552 S1
    WiFi reported error: no known networks found
    Wifi module is idle



  • Check the Case of the names it is important
    earlier you had SSI with caps in it now you dont please check carefully



  • Have you by any chance changed your Router wifi with Mac address filtering? I had filtering on and forgot to put in the
    rule. Check you router and see if the Duet is trying to connect.

    Also do you have DHCP on?



  • @Dougal1957:

    Check the Case of the names it is important
    earlier you had SSI with caps in it now you dont please check carefully

    I have change SSID in router so nothing is with caps.



  • @Synapsis:

    Have you by any chance changed your Router wifi with Mac address filtering? I had filtering on and forgot to put in the
    rule. Check you router and see if the Duet is trying to connect.

    Also do you have DHCP on?

    Have check all and no Mac adress filter is on,

    Duet dont even try to connect to router, i start to belive y´that the wifi module is faulty on this duet board.


  • administrators

    Have you tried reinstalling the WiFi firmware using M997 S1 ? Does it report any errors while it is installing?



  • @dc42:

    Have you tried reinstalling the WiFi firmware using M997 S1 ? Does it report any errors while it is installing?

    I have tryed out that 20times already its the same, no error reported while install.

    I have tryed all out now, reflashed old FW still the same it do not work.

    No i have no more ide how to solv this.

    You have some debug tool for wifi?.



  • Have format SD card and put in all new that the card was shipped with, erased board and flash duetwifi fw from bossa and flash latest duetwifi server from pronterface. Then use YAT to put in network SSID and Password reported OK.

    Restart board again and still no network grrrr i give up now its something wrong with wifi module in this board. 2 Days and still no go.

    Connecting…
    Printer is now online.

    M115
    SENDING:M115
    FIRMWARE_NAME: RepRapFirmware for Duet WiFi FIRMWARE_VERSION: 1.20 ELECTRONICS: Duet WiFi 1.0 FIRMWARE_DATE: 2017-12-23

    M552 S1
    SENDING:M552 S1
    WiFi reported error: no known networks found ( In YET the network show as OK )
    Wifi module is idle
    WiFi: scandone

    SENDING:M552 S-1
    WiFi module stopped

    M552 S1
    SENDING:M552 S1
    WiFi:
    WiFi: ets Jan 8 2013,rst cause:2, boot mode:(3,7)
    WiFi:
    WiFi: load 0x4010f000, len 1384, room 16
    WiFi: tail 8
    WiFi: chksum 0x2d
    WiFi: csum 0x2d
    WiFi: v3fff34e0
    WiFi: ~ld
    WiFi module started
    WiFi: mode : sta(60:01:94:34:3f:44)
    WiFi: add if0
    WiFi reported error: no known networks found
    Wifi module is idle
    WiFi: scandone



  • Still cant connect and have same problem… It would be nice if maker of FW/card step in and give some hint what to do in this matter..


  • administrators

    What it is saying is that when it does a network scan, none of the network SSIDs that it finds matches any of the ones you have configured using M587, You can use M587 to list the known SSIDs. This could be due to any of several causes:

    • There is no network in the M587 list whose name matches exactly the name that your router is transmitting. Use a smartphone to check that you know the exact name.

    • The signal from your router is too weak where the Duet's WiFi antenna is located.

    • Your router is not transmitting its SSID. This is an option in some routers. You can connect to a hidden SSID by specifying it in the S parameter of the M552 command.

    • Your router is not transmitting on 2.4HGz at all. Most modern routers can transmit on either or both of 2.4GHz and 5GHz.

    • The WiFi module has developed a fault in the RF section.

    One way to check the WiFi module is to configure its own SSID using M589, then start it in access point mode using M552 S2, then see if you can connect to it from a smartphone or tablet. You need to be running main firmware 1.20 and DuetWiFiServer 1.20 for this to work.



  • @dc42:

    What it is saying is that when it does a network scan, none of the network SSIDs that it finds matches any of the ones you have configured using M587, You can use M587 to list the known SSIDs. This could be due to any of several causes:

    • There is no network in the M587 list whose name matches exactly the name that your router is transmitting. Use a smartphone to check that you know the exact name.

    • The signal from your router is too weak where the Duet's WiFi antenna is located.

    • Your router is not transmitting its SSID. This is an option in some routers. You can connect to a hidden SSID by specifying it in the S parameter of the M552 command.

    • Your router is not transmitting on 2.4HGz at all. Most modern routers can transmit on either or both of 2.4GHz and 5GHz.

    • The WiFi module has developed a fault in the RF section.

    One way to check the WiFi module is to configure its own SSID using M589, then start it in access point mode using M552 S2, then see if you can connect to it from a smartphone or tablet. You need to be running main firmware 1.20 and DuetWiFiServer 1.20 for this to work.

    Strange i have SSID gixxerturbo on my router and in my phone and laptop and 2 diffrent pads and all working great… Laptop only 2.4ghz , phone i use both 2.4 and 5ghz band no problem, pads 2,4ghz working great.

    I have same SSID in M587 list as router sending out.
    Signal from router is perfect.
    My SSID is not hidden at all have check.
    I have ASUS U88 router and i use both 2,4ghz and 5ghz.

    Have made own SSID by using M589 and start in access point and phone connect perfect and i have main fw 1.20 and DuetWifiServer is 1.20.

    This is realy strange 😞

    Need to try to change more in 2,4Ghz in router and see if some happen..


  • administrators

    You said the SSID was GixxerTurbo before, now you just said it is gixxerturbo. Which is it? They are not the same.



  • @dc42:

    You said the SSID was GixxerTurbo before, now you just said it is gixxerturbo. Which is it? They are not the same.

    I did change SSID to lowercase in router and also in config.g on duetwifi so this not will be one issue.

    Can encryption be one issue? I use WPA2-Personal.
    ( 64-bitars WEP, 128-bitars WEP, WPA2-PSK, WPA-PSK, WPA-Enterprise, WPA2-Enterprise, WPS )

    So SSID is gixxerturbo.

    Info about Router ASUS RT-AC88U.

    802.11a : 6,9,12,18,24,36,48,54 Mbps
    802.11b : 1, 2, 5.5, 11 Mbps
    802.11g : 6,9,12,18,24,36,48,54 Mbps
    802.11n : up to 600 Mbit/s
    802.11ac : up to 1734 Mbps
    1024QAM (2.4GHz) : up to 1000 Mbps
    1024QAM (5GHz) : up to2167 Mbps

    MIMO technology
    2.4 GHz 4 x 4
    5 GHz 4 x 4


  • administrators

    WPA2-PSK is the one supported by the WiFi module. However, if it was an encryption issue then I would expect you to get a "Wrong password" error, not a "No known networks found".

    You could try sending M552 S1 P"gixxerturbo" instead of just M552 S1. Use YAT to send the command, to make sure that the SSID is sent in the correct case.



  • @dc42:

    WPA2-PSK is the one supported by the WiFi module. However, if it was an encryption issue then I would expect you to get a "Wrong password" error, not a "No known networks found".

    You could try sending M552 S1 P"gixxerturbo" instead of just M552 S1. Use YAT to send the command, to make sure that the SSID is sent in the correct case.

    Tryed out what you say but still no go.

    When i make M587 it say gixxerturbo but when i use M552 SI P"gixxerturbo" diden`t find accesspoint… Realy strange this.



  • ooouusssccchhhhh.

    Made one Guest SSID ( asus ) and you know what!!! Now its working and connected…. Damn cant duetwifi handle long SSID name?.


  • administrators

    It should be able to handle up to 31 characters. My own SSID is 12 characters long, one more than gixxerturbo.

    Are you sure you haven't enabled MAC address filtering on your router?



  • @dc42:

    It should be able to handle up to 31 characters. My own SSID is 12 characters long, one more than gixxerturbo.

    Are you sure you haven't enabled MAC address filtering on your router?

    Yes im 1000% sure that i dont have MAC adress filtering on, did one recheck again and its on OFF in router.

    Will try to change WPA2-Personal to WPA2-Auto and see if that works ( New asus SSID have WPA2-Auto and working )..



  • Is DHCP enabled? (I know, it's a stupid question, but it is possible you configured manual IPs for all of your clients up to this point and forgot – I have done this before).


Log in to reply