Cannot Configure Access Point Mode - M589 Error



  • I cannot get the access point configured. Here are the commands I enter at the console:

    M552 S0
    M589 S"DUETABCD" P"DUETABCD" I192.168.1.100

    At this point, I receive the following error:

    Error: M589: Bad or Missing Parameter

    Here are my firmware versions:
    Firmware Electronics: Duet WiFi 1.02 or later
    Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.23
    Web Interface Version: 1.22.6

    I have tried many combinations of SSID, password and IP address and they all fail with the same error. Any help would be greatly appreciated.



  • Have you tried omitting the IP address?

    What are you using for a USB terminal software?

    Have you seen this? https://duet3d.dozuki.com/Guide/1.)+Getting+Connected+to+your+Duet/7#s10


  • administrators

    @tkstreet said in Cannot Configure Access Point Mode - M589 Error:

    M589 S"DUETABCD" P"DUETABCD" I192.168.1.100

    I just tried sending that exact command from the GCode Console of DWC, and it worked for me. Perhaps your USB terminal software is garbling the command.

    Note, there is a minimum password length of 8 characters. Recent firmware versions emit a separate error message if the password is too short, but I don't remember whether I changed that in 2.02 or 2.03.



  • I tried leaving off the IP address and I get the same error. I was actually entering the command at the console of the PanelDue. I doubt it's relevant, but the end of the IP address runs off of the text entry space to the right and out of sight, and since it's not echoed to the screen I can't verify that the entire command is in fact being sent.

    I just connected to it via USB and sent the same command in TeraTerm and it works fine.


  • administrators

    Thanks. Currently the command line entry on PanelDue does not scroll horizontally. I suspect that the command was being truncated.


Log in to reply