Problems going beyond 550 in Y direction after firmware update



  • Following a lot of problems with my Duet, particularly connected with the Wifi, I decided to install the latest firmware from duet and ooznest. as a result the y axis will now not travel beyond 550 on my 550 x 770 table. I have ensured that config.g contains correct M208 coding i.e. M208 X550 Y770 Z94 S0. I have also tried the new coding for firmware 2.02 i.e. M208 X0:550 Y0:770 Z0:94. None of these had any effect. I still get an out of range error going beyond 550. I have even input the code via YAT with no effect. Not sure what to do next. I have checked the config.g for anything out of the ordinary but nothing different. As the coding has changed for this version of the firmware I wonder if there is a problem with it



  • Can you post your config and homing files so we can have a look over them?

    If you send just M208 in the console what does it echo back?



  • I just got OK after sending through console. config.g below shows where I tried the new M208 method, I rem'd out the normal.

    ; Configuration file for Duet
    ; executed by the firmware on start-up
    ; WorkBee Firmware Version 1.0.5

    ; General preferences
    G90 ; Set absolute coordinates
    M453 ; Put the machine into CNC Modes

    ; Network
    M550 PWorkBee CNC Machine ; Set machine name
    M552 S1 ; Enable network
    M586 P0 S1 ; Enable HTTP
    M586 P1 S0 ; Disable FTP
    M586 P2 S0 ; Disable Telnet

    ; Drives
    M569 P0 S0 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P2 S0 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M584 X0 Y1:3 Z2 ; Apply custom drive mapping
    M92 X400 Y400 Z400 ; Set steps per mm
    M350 X16 Y16 Z16 I1 ; Configure microstepping with interpolation
    M566 X500 Y500 Z500 ; Set maximum instantaneous speed changes (mm/min)
    M203 X2500 Y2500 Z2500 ; Set maximum speeds (mm/min)
    M201 X150 Y150 Z150 ; Set accelerations (mm/s^2)
    M906 X2400 Y2400 Z2400 I100 ; Set motor currents (mA)

    ; Axis Limits
    ;M208 X0 Y0 Z0 S1 ; Set axis minima
    ;M208 X550 Y770 Z94 S0 ; Set axis maxima
    M208 X0:550 Y0:770 Z0:94 ; Set Them both

    ; Endstops
    M574 X2 Y2 Z2 S0 ; Set active low endstops

    ; Tools
    ;M563 P1 S"XYZ-Probe" ; Define XYZ Touch Probe Tool

    ; Custom settings
    M564 S1 H1 ; Disable jog commands when not homed
    M140 H-1 ; Disable heated bed
    M911 S21.0 R23 P"G91 G1 Z3 F1000" ; Configure power loss resume
    M501 ; Load Stored Parameters

    Homeall.g

    ; homeall.g
    ; called to home all axes

    G91 ; relative positioning
    G21 ; Set units to mm
    G1 H1 Z94 F900 ; move quickly to Z axis endstop and stop there (first pass)
    G1 Z-3 F2400 ; go back a few mm
    G1 H1 Z94 F300 ; move slowly to z axis endstop once more (second pass)
    G1 H1 X1500 Y1500 F2400 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X-3 Y-3 F2400 ; go back a few mm
    G1 H1 X1500 Y1500 F300 ; move slowly to X and Y axis endstops once more (second pass)
    G92 X550 Y520 Z94 ;Set Home Position please change to your machine size.
    G90 ; absolute positioning

    Hope this is OK



  • @colin-kent said in Problems going beyond 550 in Y direction after firmware update:

    G92 X550 Y520 Z94 ;Set Home Position please change to your machine size.

    You're forcing a set position here.

    Try sending M208 S0 and M208 S1 to see if it will echo back the actual dimensions.



  • Ive just noticed the G92 command in the homeall.g looks like that could have somethiung to do with it. Not seen that before



  • WHen I do M208 S0 it gives me x550 y770 z94. after homing I get the same answer but when I watch the head position indicator as it is homing. the figure goes to 770 and as soon as it homes it changes to 520. Im not sure why the G92 is in the homeall but the note says change to machine size. I will go do that and see what happens



  • I changed the g92 to read X550 Y770 Z94 and that cured my problem. Looks like it over rides the M208 in the config.g.
    I will call ooznest tomorrow to see what its there. Thanks for the guidance, I wouldnt thought of looking at homeall.g



  • Yes when the endstop triggers, it sets the position to that set in M208 for the max or min. Then the G92 is overriding that set position again.


  • administrators

    @colin-kent said in Problems going beyond 550 in Y direction after firmware update:

    I changed the g92 to read X550 Y770 Z94 and that cured my problem. Looks like it over rides the M208 in the config.g.
    I will call ooznest tomorrow to see what its there. Thanks for the guidance, I wouldnt thought of looking at homeall.g

    The G92 command should not be there at all. I suggest you remove it.


Log in to reply