X axis shifts sides...



  • Hey,

    weird behavior , it seems that my X axis occasional decided to go the other way than it configures - when pressing home all.

    ; Drives
    M569 P0 S0 ; Drive X goes backwards
    M569 P1 S0 ; Drive Y goes backwards
    M569 P2 S1 ; Drive Z1 goes forwards
    ;M569 P3 S0 ; Drive E0 goes backwards FEEDER
    M569 P4 S1 ; Drive Z2 (E1) forwards
    M569 P5 S0 ; Drive PRINT-HEAD 8cm (E2)
    M569 P6 S0 ; Drive PRINT-HEAD 3cm (E3)
    M569 P7 S1 ; Drive Feeder alt (E4)
    M584 X0 Y1 Z2:4 E5:6:7 P4 ; Use E1 for Z axis

    not sure whats up with it...



  • Can you post your home scripts and end stop gcodes as well? If it's happening during homing only it's most likely in the homeall.g script.



  • ; homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2 on Thu May 02 2019 17:36:54 GMT+0300

    G91 ; relative positioning
    G1 Z5 F6000 S2 ; lift Z relative to current position
    G1 S1 X-405 Y-405 F2500 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 X5 Y5 F6000 ; go back a few mm
    G1 S1 X-405 Y-405 F360 ; move slowly to X and Y axis endstops once more (second pass)
    G90 ; absolute positioning
    G1 X200 Y200 F6000 ; move to center of the bed
    G92 Z0 ; set Z to axis minimum (you may want to adjust this)
    G30 ; probe z height

    ; Uncomment the following lines to lift Z after probing
    ; G91 ; relative positioning
    ; G1 S2 Z15 F100 ; lift Z relative to current position
    ;G90 ; absolute positioning



  • This post is deleted!


  • @cj-bravo said in X axis shifts sides...:

    G92 Z0 ; set Z to axis minimum (you may want to adjust this)

    Remove that.

    Is 405mm long enough for the X and Y axis to completely travel from one end to the other?


Log in to reply