Stepper motor lost torque



  • Damn

    That didn't end well (the short to ground warnings). Pop and burning smell with this warning in DWC. Had previously checked M906 - came back with E900:900 and M913 with returned 100%. Unplugged and replugged all connectors to do with extruder to check and tried a 1mm extrude and pop.

    For reference the e0 driver now has a little hole in it



  • Just looking for a replacement chip, is it a TMC2660-PA-T or TMC2660-PA that I need to be a direct swap and is it just a case of removing the old chip and soldering the new one on?



  • before you do any chip replacement you need to go on a hunt for what was causing the problem.

    start by checking the resistance of each phase of the stepper that you had connected.


  • administrators

    @oliverracing said in Stepper motor lost torque:

    Just looking for a replacement chip, is it a TMC2660-PA-T or TMC2660-PA that I need to be a direct swap and is it just a case of removing the old chip and soldering the new one on?

    Yes that's the one. I think the -T suffix just means that it is supplied on a reel. But before you replace it, how old is your Duet? If the driver failure wasn't your fault, replacement is covered by the warranty.



  • Yeah, I'm gonna do a proper debug this weekend as thought I had but must have missed something. The TMC2660 chips had a 3 week lead time so got a few ordered anyway ~£5 each so hardly a issue if they're not the original cause but one will need replacing anyway as it has a hole in it where the magic smoke came out!

    Not sure the age of the board, I've had it nearly 6 months and it was used before I got it, the previous owner had given up with 3d printing but not due to board issues but will ask him anyway if it might still be in warranty, I suspect not as he'd given up for a fairly long time.

    I got the board free so I might just invest in a new board if there's nothing wrong with the steppers and the rest of the wiring as massively prefer it over the stock board on the Tevo.



  • There will be a PCB revision on the board itself, that may give an indication as to its age.



  • So....

    I am officially an idiot. The stepper I did my testing with the pin-out is different to the original one - making this the likely cause of the pop and smoke I'd have thought.

    I reckon wiring was the cause of the original loss of torque as a quick resistance check shows high resistance on on of the 4 wires.

    I'll replace the drivers and go from there! Any other bits I might need to change?

    Thanks for all the help, I'm sure I'll be back here when this fix doesn't work but fingers are crossed!


  • administrators

    @oliverracing said in Stepper motor lost torque:

    Any other bits I might need to change?

    If the rest of the board is working, then it's probably only the stepper driver chip that needs to be changed.



  • ahhhhhh

    Replaced the driver last night and checked all the wiring and just fired it up...

    Getting a short to ground on driver 3 (am I right in thinking that's the E0 driver?) and over temperature on 2 3 and 4. - likely that these are linked? All feel cool to the touch but only plugged on for a few seconds as didn't want too fry too much!


  • administrators

    Over temperature warnings and errors on all drivers are usually a sign that the SPI data bus between the TMC2660s and the Duet isn't working. It's better to run M122, that gives you the complete status of all the drivers. Check whether you have a solder bridge between pins of the driver you replaced.



  • So I think my board is dead, I've replaced the driver chip again and checked under magnification and theres definitely no solder bridges but getting the same error. I decided in drastic measures to remove the chip completely so we if this helps and I'm now just getting a short to ground warning on that chip - is this normal with it removed?

    Got another board on order so will see how this goes. Gonna do a ground up rebuild of my printer to check everything standalone to make sure I can rule everything out as the cause.


  • administrators

    Yes it's normal to get a short to ground warning when the chip isn't there. You can suppress it using M569 P# R-1 where # is the driver number. If that's the only problem now, you could solder in a new driver, if you need all 5 drivers working.


Log in to reply