Saving Auto Bed Compensation settings



  • How do I get Duet 3D to remember the Auto Bed Compensation settings?

    I have the following M557 command in my config.g file -

    ; Z-Probe
    M574 Z1 S2 ; Set endstops controlled by probe
    M558 P5 H5 F120 T6000 ; Set Z probe type to switch and the dive height + speeds
    G31 P500 X23 Y9 Z0.3 ; Set Z probe trigger value, offset and trigger height
    M557 X15:195 Y15:195 S20 ; Define mesh grid

    However, it doesn't seem to use these values when I run the Auto Bed Compensation command. It seems to use the default values in Duet 3D, however if I change them, then they reset every time I reload it. '

    How do I save these new settings, or get it to use the values in the config.g file?



  • check that there are no special characters in that line and that you do not overwrite them in the config-overwrite.g file



  • @vfwfw I don't use any form of bed compensation but it sounds like your settings are being overridden by the config-override.g file. You can either copy all the settings that are in the override file then delete it and the M501 at the end of your config.g file so it doesn't call it, or edit the values in the config-override.g file. If you use M500 to store values such as heater tuning, rather than putting the values into config.g then you need to keep it.



  • Do you have any of those commands in any other macros? Like bed.g or your homing files that may be over writing the ones from config.g?

    It would be unusual for those to exist in config-override.g unless you put them there yourself.


Log in to reply