Molex connector issues



  • @dc42 I have really clean crimps. Like I said. After the first one melted, I triple checked all others, now after the 5th, I'm pretty sure it's an issue with the connector. The 6th, I'll bite the bullet and pull the board and swap for screw terminals. I'm using the connectors and pins provided with the duet.
    There are no vibration or movement at the controller. The machine weighs 150lbs, top of it may vibrate as the gantries are large and doing small movements does shake things, but the base of it is solid. I initially had the current set to 2.6, to maximize the stepper torque, but lowering to 2.4 hasn't lengthened connector life at all.


  • administrators

    @kazolar, are you using the Wurth shells and crimps that we supply, or genuine Molex ones, or some unknown Chinese clones?

    Is it just the shells that are melting, or the plastic headers on the Duet too?

    How thick are the wires going into the crimps?

    btw on Duet 3 we are changing to connectors rated at 8A - 10A, because of the higher stepper motor currents supported.



  • @dc42 I am using everything supplied with the duet. The connector is getting singed, not really melting, since I don't let it get that far anymore, and troubleshoot at first sign of trouble. I'm using 24 gauge wire, I've had it happen with the stock wire which came with the nema23s, and also had it happen with the 24gauge silicone insulated extension wire. Once I remove the connector, there is just a little discoloration on the duex5 housing, no real damage there, but connector is not fusing with the housing, typically one pin ends up charring and the z starts acting funny since it's 1 of 4 lead screws it's pretty obvious when it happens and the machine tries to twist the bed. When I removed it last time it happened, I could have probably reused the connector since it really wasn't charred much, but I didn't, I still have spares from my duet/duex5 packages. All I had to do was remove the charred crimped pin (female side) and crimp a new one and fit it into a new connector making sure everything locks in properly. I got my duex5 2 years ago, have the design been updated? My duet2 is newer has the blade fuses. Curiously enough no more i2c issues.


  • administrators

    You could try using genuine Molex shells and crimp pins, because they are rated at 4A instead of 3A. I don't know what the difference is, but the dimensions are obviously slightly different because Wurth crimp pins won't lock into Molex housings. I've just measured the width and depth of the male connector pins on a Duet, and they are almost exactly the same as on a genuine Molex KK header.



  • @dc42 I have used a number of genuine molex connectors and pins on other steppers, but it's a bit of a tighter fit, they lock in differently. I can try it on the z, I have a bunch of molex connectors. It's either I go all in and remove the molex headers off the board for screw type connectors which would be non-trivial surgery, run it until it has a problem, and swap for genuine molex at that point, btw duet supplied pins fit perfectly fine in the genuine molex connectors, I have that combination in a few fan headers. Or proactively open it up and swap all the beige duet provided connectors for molex with molex pins?



  • @dc42 ps - I don't use any chinese clones when it comes to electrical components, and really nothing else in this machine, learned the hard way when I tried Chinese linear rails, now all hiwins. All the silicone wires are imported from Hong Kong. Last thing I need is something to go poof because I cheaped out on a connector or a wire. Kinematics is hard enough to get right on a quad idex, then to complicate things with connector problems.



  • Regular 24 gauge is only rated for 2A at room temperature, the silicone stuff is rated higher, but that is just because the insulation has a higher melting point not because the same amount of copper can carry more current; the connectors might need to be de-rated if running at elevated temperature?

    Still weird its just one pin unless I read it wrong? Might be worth while re-soldering that one pin, wick up old tin, get some good flux on there, solder it and clean up.



  • @bearer The steppers are rated at 2.8a.
    And maybe I wasn't clear, but STOCK wiring that came with the stepper had this happen. Yes one pin get singed, on the stepper female connector, not the board. The board mating connection housing only has some mild discoloration. The rating of the wire is interesting, and would make sense if only the steppers which had extensions on them had a problem, but that's not the case. I may add a current meter in line with one of the steppers to check what the actual current draw per phase is, I took multiple temp readings with an ir thermometer, and the wire is not even warmer than ambient (did this while the bed was doing a long move), so it's not an issue of current exceeding the wire capacity, it's an issue with the connector. I know this because when I took the last one that failed apart I pried the singed pin open and the wire was perfectly fine inside. Such that I was able to crimp a replacement pin. I've had this happen just one time on another machine which used Dupont connectors and it happened after over 2 years of operation. In my experience this usually only happens when the connector is not making a clean connection with the pin, and my concern is that these molex connectors - by design, can't, the spring action required to keep it secured is not enough for it not to arc at some point.



  • @dc42 genuine Molex shells and pins have worked and I have not had a single blown connector since switching to them, and have done a lot of calibration routines and started doing test prints again. I also have switched a couple of other steppers to use molex shells -- next time I have to service the controller I'll switch them all. Shame that the stock ones have this issue.


  • administrators

    @kazolar said in Molex connector issues:

    @dc42 genuine Molex shells and pins have worked and I have not had a single blown connector since switching to them, and have done a lot of calibration routines and started doing test prints again. I also have switched a couple of other steppers to use molex shells -- next time I have to service the controller I'll switch them all. Shame that the stock ones have this issue.

    Thanks for the feedback. Can you confirm that you used the same crimping tool and technique when you crimped the Molex pins as you did when you crimped the Wurth pins that we supply? How the pins are crimped makes a lot of difference.



  • @dc42 I have a simmilar experience but with the molex on the top side of the smart effector. I've been fighting with it since day one, the continuous movement causing jumps on temp readings. I've been planning to start a thread about it: I'd like to replace the connector alltogether, and was courious what would you recommend? (As I understand micro-fit has a different pin distance, so I can't use that)



  • @dc42 I crimped the pins the same way. I wasn't sure it would make a difference, but I had them on hand, and gave it a shot, I'm almost 30 hours into a print which is intended to stress every aspect of the machine, doing a lot of z hops, and so far everything is fine. Previously the wurth connectors would get singed a few hours into just calibration of the machine which takes a few hours. BTW those problems started after I switched my lead screws from 4 start to single start, I obviously lowered z speeds, etc since the steps per mm went to 1600. I haven't had issues with wurth connectors on 2a steppers, but on 2.8 nema23s (configured at 2.4a) they didn't hold up. Also no i2c issues anymore either, so all is doing well.


Log in to reply