Duet 2 Wifi randomly shutoff and won't power back on

  • 24V PSU
    Momentary push button with SSR connected to PS_ON

    Last night I was leveling my bed and my printer randomly shutdown. I tried to power it back on but it wouldn't stay running. after extensive wiring troubleshooting I decided to start fresh and install a backup Duet 2 1.04 board, PSU, SSR, switch, and new wiring. Nothing else is connected to the board except VIN power and ground and the PS_ON to the SSR.

    When I hold the momentary button down the green 3.3v, red 5v, blue VIN, red diag LED turns on. I was able to get it connected through USB and use Bossa to upload the firmware. The device shows in device manager as Duet 2 wifi.

    I connected with YAT and configured the web server so I can now connect through the webpage but nothing works to get the board to power on and to run config.g

  • Update:

    After updating the firmware through the web interface the Diag LED is no longer on.

    For some reason the printer doesn't want to power on from M80

  • Update:

    Printer is running but M80 does not work. I had to install a normal on off switch for it to stay powered on

  • administrators

    @dhusolo, normally I would say that it sounds like the PS_ON mosfet has failed. But it's unlikely to have failed on 2 Duets, unless it's because of a fault in the PSU.

  • @dc42 agreed. Is there a work around where I can still use that function or another way to test?

  • @dc42 Strangely enough I moved from the 5V PS_ON pin to an open 3.3V endstop pin and it works now...

Log in to reply