Timeout on activating wifi



  • Everything in the initial setup went pretty smooth, aside from needing to use Device Manager (Win7) to install the driver. (Unrelated – I also hooked up an older PanelDue and updated its firmware at the same time. It was very easy to use the Windows GUI version rather than trying to get the Windows command prompt to find bossac.)

    Then I activated wifi as instructed, and everything worked, but when I applied changes to the config file to uncomment the wifi command, the web interface reported a timeout ("An AJAX error has been reported" etc)and disconnected. Reconnecting worked fine.

    Didn't seem to cause any problems, just reporting the error.

    Could be related or not, but after doing all that, Repetier Host kind of crapped itself. The terminal log reported a bunch of nonsense and then Repetier Host crashed when I tried to disconnect. Is there an issue with using wifi, USB, and PanelDue all be used at the same time?



  • I saw a similar Ajax error but it didn't seem to matter. I don't have a paneldue. Just repetier host and the duet web service.


  • administrators

    Hi Ryan, the Ajax error when applying changes after editing config.g is nothing to worry about. It's because I haven't yet updated DuetWebControl to allow for the extra time taken by the WiFi module to reconnect to your access point after a restart.

    The issue with Repetier Host is more worrying. There is no known issue with using USB, WiFi and PanelDue all at the same time. I have done that frequently while testing the firmware, but using Pronterface instead of Repetier Host.

    Please open config.g again and check that it still includes this line:

    M555 P2 ; Set output to look like Marlin

    and doesn't have another M555 line later in the file.


  • administrators

    Hi again,

    I just installed Repetier host and connected it to the Duet WiFi. I started getting these messages in the Repetier message log after connecting the web interface:

    12:12:05.920 : Request: status?type=1 fragment 2147483648
    12:12:05.920 : Resp 2147483648: 000100c8 00000180 {"st…s
    12:12:06.222 : Request: status?type=1 fragment 2147483648
    12:12:06.223 : Resp 2147483648: 000100c8 00000180 {"st...s
    12:12:06.519 : Request: status?type=1 fragment 2147483648
    12:12:06.519 : Resp 2147483648: 000100c8 00000180 {"st...s

    Is this what you were referring to? What this means is that Repetier has sent M111 S1 to turn on debugging The messages are summaries of the communication between the WiFi module and the main processor on the Duet WiFi. I found that I can stop Repetier enabling debugging if I turn off all 4 of the "Debug Options".

    HTH David



  • Yeah, that was the kind of message I was seeing. The Repetier Host crash was probably from attempting to disconnect when it had already lost connection, but who knows. I'll let you know if I can repro.



  • Try pronterface. Its a really good tool for anything that isn't running repetier, as it skips out on a lot of "features" (things that repetier firmware has that most things don't) that RH adds.



  • Last time I used Pronterface, I had no end to troubles with it. (Might've been Smoothieoboard USB issues though, don't know.) I can try it again if I have more RH issues.



  • It might be different on OS X/Linux. I find it easier to run pronterface on linux since it requires the least dependencies vs repetier host (python utilities vs mono and monodevelop), and its a really easy install on OS X (all the python utils are preinstalled so its just execute the .app package). Not sure how it is on windows since I only use it for gaming.


 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.