Help! DWC Disconnects and Drops after extensive troubleshooting



  • I've been using my Duet2Wifi for around a year now with no issue up until several weeks ago.

    Initially, the problem that I had was like the Duet wasn't connected to the network, and thus I would be unable to connect to it over the network via my PC, so I thought. What was actually occurring was that I had to continuously reload the page over and over again and eventually the DWC interface would come up. During this process, the majority of the time the interface would only partially load. For instance, only the indication shown at the top left corner of the page would come up, but it would display no values. Sometimes, the DWC interface will load but not populate with values and actually connect to the board. Now, even if I keep reloading the page, and if it does manage to initialize, it will disconnect almost immediately and display the host unreachable message, sometimes if I let it sit it reconnects, most times it does not. No error message is displayed, no AJAX errors, no physical disconnection from the network...I'm at a loss. If I click to reload the page the same cycle continues. I have to keep refreshing or reloading the page in the hopes that eventually it will catch and load the DWC completely, and that I will actually be able to communicate with the board.

    Also, whenever I enter M122, everything shows as normal with no error messages displayed and my signal strength is -45 or better.

    Before posting here I scoured the forums for other people who've had this issue and I went through several of the troubleshooting steps I've seen posted, but it seems like none of the people who have had this problem have achieved a resolution, or if they have they have not posted it here on the forum. I also know for certain that the wifi module is not disconnecting from my modem whenever I'm experiencing these issues because I've actively monitored my device traffic and seen the blue light still indicating solid on the Duet throughout. I'm also certain its not a wifi traffic/congestion issue, and the fact the Duet never actually disconnects from the modem is proof of that.

    What's strange is that I'm still able to upload STL's in Cura 4.3 via the Duet plug-in directly to my printer with no issue. It will upload direct from Cura without any disconnects, so I believe the problem to be something exclusively wrong with the DWC aspect of my board in one way or another.

    It's also important to note this problem is not exclusive to my PC. I tried accessing the DWC from several devices and had the exact same result on all of them.

    Here's what I've tried:
    -Reloading Firmware Completely
    -Reloading the Wifi Server Firmware only
    -Reloading the DWC Firmware only
    -Physically removing anything blocking a clear path to my modem from my Duet
    -Formatting and re-populating the SD card with the necessary Firmware/Config files
    -Attempted accessing the DWC from other devices on my network

    Please help!! Any ideas or possible solutions are much appreciated!!



  • https://duet3d.dozuki.com/Wiki/WiFi_disconnections_and_AJAX_timeout_errors

    i would try this step and see if you get disconnects here as well

    Consider running the Duet 2 Wifi in access point mode. This way the Duet creates a network which you can join from your wireless enabled device, (eg, PC, tablet, phone, etc.) and connect to the DWC to perform further configuration.



  • Thanks for the suggestion!

    I would love to try that, but am completely unaware of how to go about doing it. Do you know if there's any kind of write-up on how to do this?





  • Thanks!

    I'll give this a try this evening and report back.



  • No success.

    I tried running it in access point mode with no success. I also upgraded to the latest DWC, and still no change.


  • administrators

    Which version of DWC are you using? DWC2 is in some ways more demanding than DWC1.

    Some possible reasons for the WiFi behaviour changing:

    • You have acquired another device that uses the 2.4GHz band, e.g. cordless phone or baby monitor
    • Your close neighbours have got a new router, or changed WiFi channel
    • Your router is set to automatic channel switching and has changed channel.

    I suggest you check which channel your router is set to and try changing it. There are smartphone apps that will show you which channels are in use.

    Also use M122 to check that you are running DuetWiFiServer version 1.23.



  • Thank you for your response!

    I've attempted to update the DuetWifiServer to version 1.23, but cannot get it to go past version 1.21. I've tried uploading it directly through the DWC and by drag/dropping it into the /sys folder and applicable folders within on the SD card. I've also tried multiple SD cards to see if my problem was a bad SD card.

    I will try changing the wifi channel and report back with my findings. As far as new devices go, there is nothing else new on the network that was not previously there when it was functioning correctly.



  • @alexd607 said in Help! DWC Disconnects and Drops after extensive troubleshooting:

    I've attempted to update the DuetWifiServer to version 1.23

    what is the error message?



  • No error message.

    When doing it via the DWC, it acts like it's going to take but then never restarts completely. I get prompted to install the firmware, select yes, and then it does its thing but freezes. I've left it completely alone for upwards of 20 minutes after uploading the new firmware and it never recovered or rebooted on its own. I have to physically cycle the power and then once rebooted it is reverted back to 1.21.



  • Also,

    @dc42 changing the wifi channel had no effect.



  • @alexd607 said in Help! DWC Disconnects and Drops after extensive troubleshooting:

    No error message.

    please see
    https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware
    try upgrading via usb

    the wifi firmware has to match the duet firmware.



  • @Veti
    I was able to successfully update the firmware to the latest versions, to include the wifi firmware.

    Seems like the problem may be resolved, but it's too early to tell just yet. I'll report back either way in case someone else finds themselves facing this issue as well.



  • @Veti @dc42

    It seemed to improve for a time, but has since worsened.

    DWC constantly disconnects now to the point that it's impossible to make changes in my config.g file without powering down and removing the SD card...

    Any ideas or further troubleshooting tips would be greatly appreciated. What are my options for being able to print if I'm unable to restore DWC functionality?


  • administrators

    Please confirm which versions of the main firmware, DuetWiFiServer, and Duet Web Control you are now running (as reported by Duet Web Control), and the WiFi signal strength reported by M122.



  • @alexd607 WiFi can be a real pain. Not sure it's a network issue but it would be good to rule it out with a simple ping test while the issue is occurring. https://iihelp.iinet.net.au/How_to_run_a_ping_test

    It would also be good to leave the ping test running to see what the packet loss is over time.



  • @mwolter

    I'll be sure to give this a try and report back with what I find! At this point, anything is worth a shot.



  • @dc42 Here's what I get back when entering m122.

    Here's what my console looks like:
    dwc console.JPG

    M122
    

    === Diagnostics ===
    RepRapFirmware for Duet 2 WiFi/Ethernet version 2.04 running on Duet WiFi 1.02 or later
    Board ID: 08DGM-9T6BU-FG3S0-7J1F6-3S06T-9A43F
    Used output buffers: 3 of 24 (11 max)
    === RTOS ===
    Static ram: 25680
    Dynamic ram: 92808 of which 356 recycled
    Exception stack ram used: 268
    Never used ram: 11960
    Tasks: NETWORK(ready,628) HEAT(blocked,1232) MAIN(running,3744) IDLE(ready,200)
    Owned mutexes:
    === Platform ===
    Last reset 00:00:14 ago, cause: software
    Last software reset at 2019-12-04 09:23, reason: Heat task stuck, spinning module FilamentSensors, available RAM 11568 bytes (slot 1)
    Software reset code 0x40ad HFSR 0x00000000 CFSR 0x00000000 ICSR 0x0041f80f BFAR 0xe000ed38 SP 0x20004a9c Task 0x4e49414d
    Stack: 0044d38f 004451d6 6100f000 3f000000 00000000 00000000 00000000 3331bb4c 41880000 3e178897 3e1cd04f be09b238 3e3a3fd4 00000000 00000000 00000000 3f800000 3f800000 3f000000 20000010 20003258 20002b88 0044d38f
    Error status: 0
    Free file entries: 10
    SD card 0 detected, interface speed: 20.0MBytes/sec
    SD card longest block write time: 0.0ms, max retries 0
    MCU temperature: min 28.5, current 29.1, max 29.2
    Supply voltage: min 24.3, current 24.4, max 24.5, under voltage events: 0, over voltage events: 0, power good: yes
    Driver 0: standstill, SG min/max not available
    Driver 1: standstill, SG min/max not available
    Driver 2: standstill, SG min/max not available
    Driver 3: standstill, SG min/max not available
    Driver 4: standstill, SG min/max not available
    Date/time: 2019-12-04 09:23:41
    Cache data hit count 38669759
    Slowest loop: 1.17ms; fastest: 0.06ms
    I2C nak errors 0, send timeouts 0, receive timeouts 0, finishTimeouts 0, resets 0
    === Move ===
    Hiccups: 0, FreeDm: 160, MinFreeDm: 160, MaxWait: 0ms
    Bed compensation in use: none, comp offset 0.000
    === DDARing ===
    Scheduled moves: 0, completed moves: 0, StepErrors: 0, LaErrors: 0, Underruns: 0, 0
    === Heat ===
    Bed heaters = 0 -1 -1 -1, chamberHeaters = -1 -1
    Heater 2 is on, I-accum = 0.0
    === GCodes ===
    Segments left: 0
    Stack records: 1 allocated, 0 in use
    Movement lock held by null
    http is idle in state(s) 0
    telnet is idle in state(s) 0
    file is idle in state(s) 0
    serial is idle in state(s) 0
    aux is idle in state(s) 0
    daemon is idle in state(s) 0
    queue is idle in state(s) 0
    autopause is idle in state(s) 0
    Code queue is empty.
    === Network ===
    Slowest loop: 39.88ms; fastest: 0.00ms
    Responder states: HTTP(0) HTTP(0) HTTP(0) HTTP(0) FTP(0) Telnet(0) Telnet(0)
    HTTP sessions: 1 of 8

    • WiFi -
      Network state is running
      WiFi module is connected to access point
      Failed messages: pending 0, notready 0, noresp 0
      WiFi firmware version 1.23
      WiFi MAC address 84:f3:eb:83:48:e5
      WiFi Vcc 3.39, reset reason Power on
      WiFi flash size 4194304, free heap 24384
      WiFi IP address 192.168.1.151
      WiFi signal strength -22dBm, reconnections 0, sleep mode modem
      Socket states: 0 0 0 0 0 0 0 0

    @mwolter I did the ping test several times, and they all came back successful with 0 packet loss.



  • @alexd607 said in Help! DWC Disconnects and Drops after extensive troubleshooting:

    Last software reset at 2019-12-04 09:23, reason: Heat task stuck, spinning module FilamentSensors, available RAM 11568 bytes (slot 1)

    That's interesting. Are you having problems with the filament sensor? Is the wiring running close to stepper motors or PanelDue (if fitted)?

    Ian



  • @droftarts

    I don't have a filament sensor or panel due fitted.

    It's strange that that is what it's reporting considering the last reset was done by me via M112.


Log in to reply