Z homing is not working (but G30 does...)



  • Hi,

    most likely a stupid thing, but it just boggles my mind and I can't find a solution...
    I was just about to finish the set up of my "homebrew" cartesian printer with a Maestro board. Up to now everything is working - but the Z probe. The funny thing is, that the static test (as described here) is working (Z probe reading in DWC is 0, when triggering its showing 1000) and also the dynamic test using G30 is working (The probe triggers and the Z movement stops). But when I try to home Z (G28 Z) the head crashes into the bed.
    Can anybody pls explain?

    The printer is a cartesian (own design), the probe is (for now) a PINDA2 w/ 3 contacts wired (brown (5V) and blue (GND) connected to Panel Due pins, black connected to Z PROBE IN), as the Maestros board revision is 1.0 I used a diode (as described here). BTW: I already tested if blue/brown were simply switched (as mentioned in another post).
    The config.g etc. was generated with the RRF configtool, Firmware on the Maestro is version is 2.04 (2019-11-01b1)

    gunn

    This is my config.g:

    ; Configuration file for Duet Maestro (firmware version 2.03)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Sun Nov 17 2019 21:05:31 GMT+0100 (Central European Standard Time)
    
    ; General preferences
    G90                                      ; send absolute coordinates...
    M83                                      ; ...but relative extruder moves
    M550 P"X"                         ; set printer name
    M918 P1 E4 F2000000                      ; configure direct-connect display
    
    ; Network
    M552 P0.0.0.0 S1                         ; enable network and acquire dynamic address via DHCP
    M586 P0 S1                               ; enable HTTP
    M586 P1 S0                               ; disable FTP
    M586 P2 S0                               ; disable Telnet
    
    ; Drives
    M569 P0 S0                               ; physical drive 0 goes backwards
    M569 P1 S1                               ; physical drive 1 goes forwards
    M569 P2 S1                               ; physical drive 2 goes forwards
    M569 P3 S1                               ; physical drive 3 goes forwards
    M584 X0 Y1 Z2 E3                         ; set drive mapping
    M350 X16 Y16 Z16 E16 I1                  ; configure microstepping with interpolation
    M92 X160.00 Y160.00 Z1600.00 E254.65     ; set steps per mm
    M566 X600.00 Y600.00 Z18.00 E300.00      ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00 E6000.00  ; set maximum speeds (mm/min)
    M201 X1500.00 Y1500.00 Z100.00 E10000.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800 E700 I30             ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                  ; Set idle timeout
    
    ; Axis Limits
    M208 X-3 Y-3 Z0 S1                       ; set axis minima
    M208 X320 Y320 Z300 S0                   ; set axis maxima
    
    ; Endstops
    M574 Z0 S0                               ; set active low and disabled endstops
    M574 X1 Y2 S1                            ; set active high endstops
    
    ; Z-Probe
    M558 P5 H5 F120 T6000                    ; set Z probe type to switch and the dive height + speeds
    G31 P500 X25 Y5 Z0.75                    ; set Z probe trigger value, offset and trigger height
    M557 X20:300 Y20:300 S40                 ; define mesh grid
    
    ; Heaters
    M307 H0 B0 S1.00                         ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4092 R2200              ; set thermistor + ADC parameters for heater 0
    M143 H0 S130                             ; set temperature limit for heater 0 to 130C
    M305 P1 T100000 B4725 C7.060000e-8 R2200 ; set thermistor + ADC parameters for heater 1
    M143 H1 S275                             ; set temperature limit for heater 1 to 275C
    
    ; Fans
    M106 P0 S0 I0 F500 H-1                   ; set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1 T45                ; set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    
    ; Tools
    M563 P0 S"Main" D0 H1 F0                 ; define tool 0
    G10 P0 X0 Y0 Z0                          ; set tool 0 axis offsets
    G10 P0 R0 S0                             ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    T0                                       ; select first tool
    
    
    


  • please post your homez.g and homeall.g



  • Hi,

    In your config.g file you have a M574 command declaring that the Z axis has no endstop.

    I think you want M574 Z1 S2

    Frederick



  • That was fast...:-)

    homeall.g:

     homeall.g
    ; called to home all axes
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Sun Nov 17 2019 21:05:31 GMT+0100 (Central European Standard Time)
    G91                    ; relative positioning
    G1 H2 Z5 F6000         ; lift Z relative to current position
    G1 H1 X-328 Y328 F1800 ; move quickly to X and Y axis endstops and stop there (first pass)
    G1 H2 X5 Y-5 F6000     ; go back a few mm
    G1 H1 X-328 Y328 F360  ; move slowly to X and Y axis endstops once more (second pass)
    G1 H1 Z-305 F360       ; move Z down stopping at the endstop
    G90                    ; absolute positioning
    G92 Z0                 ; set Z to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    ;G91                   ; relative positioning
    ;G1 S2 Z5 F100         ; lift Z relative to current position
    ;G90                   ; absolute positioning
    
    

    homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.2 on Sun Nov 17 2019 21:05:31 GMT+0100 (Central European Standard Time)
    G91               ; relative positioning
    G1 H2 Z5 F6000    ; lift Z relative to current position
    G1 H1 Z-305 F1800 ; move Z down until the endstop is triggered
    G92 Z0            ; set Z position to axis minimum (you may want to adjust this)
    
    ; Uncomment the following lines to lift Z after probing
    ;G91              ; relative positioning
    ;G1 H2 Z5 F100    ; lift Z relative to current position
    ;G90              ; absolute positioning
    


  • i suggest that you recreate the config in the configurator.

    your config was from when you did not have a z probe.

    homez should look like this

    G91 ; relative positioning
    G1 H2 Z5 F6000 ; lift Z relative to current position
    G90 ; absolute positioning
    G1 H2 X15 Y15 F6000 ; go to first probe point
    G30 ; home Z by probing the bed



  • @Veti and @fcwilt: Thank you!!! The combination of recommendations did the trick, the homing is working now.

    So, I can continue working on this thingy....:-)

    Cheers, gun


Log in to reply