DuetWifiServer Upgrade failed: `failed due to comm write error`



  • Hi all,

    I am having issues upgrading DuetWifiServer on my Duet Wifi (Reported as version Duet WiFi 1.0 or 1.01).

    Any help would be greatly appreciated!

    Context

    The printer is going through an upgrade, I've installed linear rails and am also upgrading to a Smart Effector.
    Before re-wiring to meet the connector needs of the smart effector, I decided to upgrade the main board to a recent version of the firmware

    The main issue: The main firmware has upgraded but the Wifi Server always fails to upgrade

    Initial Versions:
    
    DuetWifiFirmware = 1.20
    DuetWifiServer = 1.20
    DuetWebControl = 1.20
    
    Planned Upgrade Path:
    
    1.20 -> 1.21 -> 2.04 (OR 2.05RC1)
    

    Also, I have read through all of the whats new section and can confirm no changes would impact the upgrade path for my printer

    Summary of steps completed so far

    Upload iap4e.bin (57.6 KiB) from 1.21 release page
    Upload DuetWifiFirmware 1.21 (DuetWiFiFirmware.bin, 371.6 KiB)

    Noted from 1.21 installation instructions that DuetWifiServer can be installed before or after main firmware so updating main firmware first

    Allow UI/upload to kick off update

    Update completes successfully for 1.21 Duet WifiFirmware

    Upload DuetWifiServer 1.2.1 (DuetWiFiServer.bin, 289.9 KiB)

    Allow UI/upload to kick off update

    Disconnects, Wait 3 minutes, cannot reconnect via UI
    Cannot refresh page, connection time out
    Power Cycle Printer
    Reconnect to UI and check version

    DuetWifiServer version still shown as 1.20

    Repeat above process: same result

    Initiate upgrade using PanelDue with M997 S1
    PanelDue shows error at end of process and power must once again be cycled to access the UI

    Attempt upgrade of DuetWebControl via UI
    Upload DuetWebControl (DuetWebControl.zip, 561 KB)
    Update completes succesfully for 1.21 DuetWebControl

    Repeat above tests to see if this has made a difference
    Result -> All fail

    Forum Search Results:

    https://forum.duet3d.com/topic/5646/duet-wifi-not-updating-firmware-when-installing-2-0/4
    For the above, I have confirmed I have updated the iap4e.bin file

    https://forum.duet3d.com/topic/9807/failed-to-add-ssid-to-remember-list/2
    From the above, even though not directly related, I've used the commands to do the following:


    1 - Put WiFi into IDLE (M552 S0)
    2 - Activate WiFi (M552 S1)

    Retry update - Failed with same error
    Power Cycle

    1 - Put WiFi into IDLE (M552 S0)

    Retry update - Not started because its in idle mode?
    Power cycle


    https://forum.duet3d.com/topic/2340/upgrading-duet-wifi-to-v1-19/3
    For the above, suggests I have an early version of the product and this may continue to always fail?
    Using the suggestion of running only over 5v (as above was all at VIN Power of 24v)

    Same result 2 times

    Attachments

    1 - DuetWifi - Initial Version Information - Duet3D System Information screen showing versions prior to upgrade steps
    Duet2Wifi - Version Information.png
    2 - Duet2Wifi - Post Upgrade Version Information - Duet3D System Information screen showing versions after upgrade steps
    Duet2Wifi - Upgraded Version Information.png
    3 - PanelDue Error - Picture of PanelDue reporting update error
    PanelDue Error.jpg
    4 - Uploaded Files - Screenshot of uploaded files to UI
    Duet2Wifi - File Information.png



  • any reason you are upgrading to a firmware that is over 18 months old 2.04 is the latest full release and there is 2.05RC1 released just a few days ago.



  • @Dougal1957 Hi, thanks for posting so quickly!

    The only reason for this was caution over compatibility between versions. Due to the naming convention change in the firmware files, the instructions differ between 1.20 and 1.21 and therefore I decided to follow step by step there first before going to a higher number.

    If advised, I would jump straight directly to 2.05RC1, although, if the same problem occurs the WiFi server may stop functioning altogether as the firmware versions would be incompatible (2.05RC1 requires 1.23 DuetWifiServer)



  • @dave-poltorak I actually wonder if the IAP file is for later FW I can't remember when that was changed but you could copy the FW File (Correctly named) to the sys folder and then issue a M997 S1 I think it is. Yes just checked it is S1

    The file needs to be named DuetWiFiServer.bin

    HTH this goes back so far i may be slightly off but I don't think so



  • I've tried a few variations based on your suggestions, I've tried it this way before and is listed above but wanted to follow up on any advice given.

    Manually Moving update files to SD and issuing M997 S1 from Web UI requires power cycle to access again
    Manually moving update files to SD and issuing M997 S1 from PanelDue results in the same error. Have tried this 4 times without any luck.

    I have now also downloaded the necessary files for 2.05RC1 and can confirm that my board is now running the main firmware at this version with the latest version of DuetWebControl.

    I attempted all the various upgrade mechanisms again but alas, still the same error.



  • Success!

    I modified my config.g to not start the WiFi at startup and the M997 S1 was successful in uploading the firmware. This wasn't listed in any of the documentation sites but am very happy that all firmware is now upgraded. Might be worth adding to documentation somewhere?

    Thanks!


Log in to reply