G0 can control NEMA23, but G92 can't get response



  • I have a workbench machine. When connecting the NEMA23 motor for testing, I can make the motor rotate by using g0x20, but I use the G92 X100 parameter to test and find that the stepping motor has no response. Here is my configuration file. Please help me to see what went wrong

    FIRMWARE_NAME: RepRapFirmware for Duet 2 WiFi/Ethernet FIRMWARE_VERSION: 2.05 ELECTRONICS: Duet WiFi 1.02 or later FIRMWARE_DATE: 2019-12-13b1
    ok

    ; General preferences
    G90                                                ; send absolute coordinates...
    M83                                                ; ...but relative extruder moves
    M550 P"WorkBee_CNC"                                  ; set printer name
    
    ; Network
    M551 P"123123******"                                 ; set password
    M552 S1                                            ; enable network
    M586 P0 S1                                         ; enable HTTP
    M586 P1 S0                                         ; disable FTP
    M586 P2 S0                                         ; disable Telnet
    
    ; Drives
    M569 P0 S1                                         ; physical drive 0 goes forwards
    M569 P1 S1                                         ; physical drive 1 goes forwards
    M569 P2 S1                                         ; physical drive 2 goes forwards
    M584 X0 Y2 Z1                                      ; set drive mapping
    M350 X16 Y16 Z16 I1                             ; 配置不带插补的微步
    M92 X2560.00 Y2560.00 Z2560.00                  ; 设置每毫米步长
    M566 X900.00 Y900.00 Z12.00                        ; set maximum instantaneous speed changes (mm/min)
    M203 X6000.00 Y6000.00 Z180.00                     ; set maximum speeds (mm/min)
    M201 X500.00 Y500.00 Z10.00                        ; set accelerations (mm/s^2)
    M906 X2000 Y2000 Z2000 I10                         ; set motor currents (mA) and motor idle factor in per cent
    M84 S30                                            ; Set idle timeout
    
    ; Axis Limits
    M208 X0 Y0 Z0 S1                                   ; set axis minima
    M208 X824 Y780 Z122 S0                             ; set axis maxima
    
    ; Endstops
    M574 X2 Y2 Z2 S1                                   ; set active low and disabled endstops
    
    ; Z-Probe
    M558 P0 H3 F120 T6000                              ; disable Z probe but set dive height, probe speed and travel speed
    M557 X15:215 Y15:195 S20                           ; define mesh grid
    
    ; Heaters
    M140 H-1                                           ; disable heated bed
    
    ; Fans
    M106 P0 I-1 H-1 A20 R24000
    ;M106 P1 S0.7 I0 F100 H0 T50
    
    ; Tools
    M563 P0 S"CNCSpindle" D-1 H-1
    G10 P0 X0 Y0 Z0                                    ; set tool 0 axis offsets
    G10 P0 R0 S0                                       ; set initial tool 0 active and standby temperatures to 0C
    
    ; Custom settings are not defined
    
    ; Miscellaneous
    M501                                               ; load saved parameters from non-volatile memory
    ;M911 S10 R11 P"M913 X0 Y0 G91 M83 G1 Z3 E-5 F1000" ; set voltage thresholds and actions to run on power loss
    T0                                                 ; select first tool
    M453 S"CNCSpindle" P20 I0 T0 R24000
    ; Change to workplace coordinates set 1
    G54
    


  • g92 just sets the current position to the specified value

    so G92 X100 sets the current location to X100 it will never move a motor



  • Oh,thank you.


Log in to reply