Can't login to web interface



  • I've tried every combination I can think of, but no username and password combo works on the web interface. I've tried with M550 and M551 as both the username and password, and vice versa, I've wiped the SD card, reinstalled all the firmware, reinstalled the web interface, and nothing seems to work. Has anyone experienced this?

    Currently running (after trying Release 3beta2 without success):
    M115
    FIRMWARE_NAME: RepRapFirmware for Duet 2 Maestro FIRMWARE_VERSION: 3.0 ELECTRONICS: Duet Maestro 1.0 FIRMWARE_DATE: 2020-01-03b3



  • Maybe a dumb question, but you're sure its the correct IP address? I don't have a M551 in my config at all and have never seen a password or username prompt.

    As it seems you have access to the console output of M552 without any parameters?

    edit: I.e. try without M551, or if memory serves username should be blank or reprap password as defined in M551



  • @bearer Thanks for the response.

    I was all set to say "yep, the same", but I figured the least I could do is set it to another IP address in config.d and go there.

    So. Many. Hours. Wasted.

    Looks like something else grabbed 192.168.1.77 while my printer was offline and wouldn't let it go, causing a conflict. I just set Duet to 192.168.1.222 and the web interface came up without issue.

    Bleh. Much appreciated!


Log in to reply