Weird Ripples on My Maestro rrf3 Conversion



  • I have rrf 3.01 beta 2 on a railcore zl, a seemecnc 3 and an Ultibot D300 so I decided to buy a maestro and try it in on 3C1BBBF0-97C9-44A4-9B9F-07F9DCC5716B.jpeg an ender 3 pro. Everything has gone fine with all of the machines, but I noticed something weird on the ender 3 that I don't remember seeing before. There are these micro pulses on the first layer, .2mm on pei.
    They are a bit better when the infill is printed only in x or y. 45 degrees us the worst. Ive trued babysrepping up and down .02, .04, .06. No real change. This was printed at 25mm/s. Prunting very slow say 5 makes it much better. Faster is worse and the distance between pulses gets larger. Tried changing the first layer acceleration with a variety of print speeds and no real improvement. Its all dependent on the actual print speed. This a bondtech and e3d v6 , .4 nozzle. Also print temperatures dint seem to change it.
    I’ll ask fir your indulgence in advance as this probably has nothing to do with the maestro or rrf3 but there are a lot of smart people here and I’m stumped. Thx in advance for any ideas.



  • Sorry for the spelling. This was on my iPad.


  • Moderator

    @4lathe Hard to say. I'd usually put this down to the extruder pulsing, either due to settings or coarse teeth. But could be the motor driver. Maybe try swapping extruder to E1. Can you post your config.g? It does look like you're over extruding, as the infill is over the perimeter. Are you running pressure advance or volumetric extrusion?

    Ian



  • ; Configuration file for Ender 3 Maestro

    ; General preferences

    G90                                       ; Send absolute coordinates...
    M83                                       ; ...but relative extruder moves
    G21                                       ; Millimeters

    Here is my config. This is with upped extruder jerk and accel with same results. No pa or volumetric. Bondtech extruder only has 20 hours on it and gears are like new. Infill is 25% overlap as set in prusaslicer. Its clearly more pronounced at turnarounds from intersection with perimeter. Thx

    ; Network

    M550 P"Ender 3"                ; Set machine name
    M552 P192.168.1.251 S1         ; Enable network and set IP address
    M553 P255.255.255.0            ; Set netmask
    M554 P192.168.1.249            ; Set gateway
    ;M555 P2                        ; Look like Marlin
    M586 P0 S1                     ; Enable HTTP

    ; Drives

    M569 P0 S0                                ; Drive 0 goes backwards
    M569 P1 S0                                ; Drive 1 goes backwards
    M569 P2 S1                                ; Drive 2 goes forwards
    M569 P3 S0                                ; Drive 3 goes backwards
    M350 X16 Y16 Z16 E16 I1                   ; Configure microstepping with interpolation
    M92  X80.00 Y80.00 Z400.00 E845.00        ; Set steps per mm
    M566 X900.00 Y900.00 Z150.00 E600.00      ; Set maximum instantaneous speed changes (mm/min)
    M203 X9000.00 Y9000.00 Z1200.00 E2400.00  ; Set maximum speeds (mm/min)
    M201 X3600.00 Y3600.00 Z100.00 E9000.00    ; Set accelerations (mm/s^2)
    M906 X800.00 Y800.00 Z800.00 E800.00 I30  ; Set motor currents (mA) and motor idle factor in per cent
    M84  S30                                  ; Set idle timeout

    ; Axis Limits

    M208 X0 Y0 Z0 S1                          ; Set axis minima
    M208 X235 Y235 Z250 S0                    ; Set axis maxima

    ; Endstops

    M574 X1 S1 P"xstop"                        ; For RRF3
    M574 Y1 S1 P"ystop"
    M574 Z1 S2                                 ; Define Z to use Probe. Home to Min

    ; Z-Probe

    M558 P9 C"zprobe.in" H5 F120 T2400  R0.5   ; For RRF3
    M950 S0 C"zprobe.mod"                      ; For RRF3
    G31  X46 Y0 Z1.6 P25
    M557 X48:195 Y35:230 P15:15

    ; Heaters

    M308 S0 P"bedtemp" Y"thermistor" T100000 B4138 R2200             ; For RRF3
    M950 H0 C"bedheat" T0                                            ; For RRF3
    M307 H0 A240.3 C608.7 D8.2 S1.00 V24.1 B0                        ; Bed
    M143 H0 S90                                                      ; Set temperature limit for heater 0 to 120C

    M308 S1 P"e0temp" Y"thermistor" T100000 B4725 R2200 C7.06e-8     ; For RRF3
    M950 H1 C"e0heat" T1                                             ; For RRF3
    M307 H1 A512.9 C267.0 D9.0 B0                                    ; V6
    M143 H1 S280                                                     ; Set temperature limit for heater 1 to 280C

    ; Fans
    M950 F0 C"fan0"
    M950 F1 C"fan1"
    M950 F2 C"fan2"
    M106 P0 S0.3 I0 F500 H-1                  ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control off
    M106 P1 S1 I0 F500 H1 T45                 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control on
    M106 P0 S0

    ; Tools

    M563 P0 D0 H1                             ; Define tool 0
    G10 P0 X0 Y0 Z0                           ; Set tool 0 axis offsets
    G10 P0 R0 S0                              ; Set initial tool 0 active and standby temperatures to 0C

    ; Automatic saving after power loss is not enabled

    ; Custom settings

    M918 P1 E4                                ; LCD 12864
    M912 P0 S-3                               ; MCU Temp offset

    M501
    T0



  • Also here is a pic with current config settings varying extrusion. From the left is 95, 85, 80%. Basically same result.AD7AC901-50F7-4C6A-90D5-036F2A2B5874.jpeg



  • Sorry from bottom to top not left to right.


  • Moderator

    @4lathe Does this happen only on the first layer? Does each motor sound smooth?

    M92 ... E845 for extrusion steps sounds far too high for a Bondtech, which is usually about 415, so about double. Are you using a 0.9º motor on the extruder?

    To test the extruder motor on the E1 header, add the following after the other M569 commands:
    M569 P4 S0 ; Drive 4 goes backwards
    You don't have an M584 (set drive mapping) command, which you should (this could be an issue as you're running RRF3.01beta2 - EVERYTHING is supposed to be defined!). Add this after the above line:
    M584 X0 Y1 Z2 E3 ; set drive mapping

    Then, if you want to change to using the E1 motor driver, change this line to:
    M584 X0 Y1 Z2 E4 ; set drive mapping
    and move the motor to the E1 motor header pins.

    Anything that could be causing issues in your config_override.g?

    Ian



  • I did all that just after I posted because E0 stopped working right in the middle of a print. It would make a small movement of the gear and then stop. Extrude or retract. I could manually feed filament and after I unloaded it, tested the gear which moved freely. The stepper would still not move the gear except for a little maybe 1/8” movement. I then switched to E1 and printed another test. Same pulses on the print. It is a .9 stepper. No config-override file.
    New fact however the factory connector between the power supply output and the wires that connect to the maestro was getting really hot. Googling showed this as a known issue. Do you think this could have anything to do with it? M122 showed no errors when I ran it even with the limping/failed E0 driver.


  • Moderator

    @4lathe Once you've sorted the power supply wiring, try a different motor. As you swapped the same motor to a different driver and experienced the same thing, it points to the motor. I vaguely recall that 0.9º motors do not make good extruder motors, but I can't remember why. Torque, possibly?

    Edit: It's possible the power supply problem caused the problem with the driver, but they actually use very little voltage and power, particularly the heated bed. So unless the voltage of the PSU was dropping to 8V (and you should get a voltage warning from the Duet at that), I doubt that's the cause of the motor pulsing.

    Ian



  • I have an ender 3 running RRF3 on a Duet 2 Maestro, it seems like your the E value in M92 is incorrect, mine is as follows...
    M92 X80.00 Y80.00 Z400.00 E101.00 ; set steps per mm

    also, you might want to reduce the current values in M906 this stops the steppers getting too hot ... (this is not your initial problem just another suggestion ...

    M906 X600 Y600 Z600 E700 I30 ; set motor currents (mA) and motor idle factor in per cent



  • @Spanners for a bondtech at 1/16th and a .9 stepper 830 ish is the correct number. My steppers get only slightly warm to the touch so no problem on the config. I use .9 steppers in all of my larger deltas and railcores.
    Re the power supply , Ill fix that tomorrow and try to find another stepper. Oh well.



  • I didn't find the reply to "is this happening only on first layer" ?
    I had similar issues when my head was too close to the bed the pressure from the nozzle would release like that, in waves .. looked bit different from what you have but worth checking out.. only makes sense if it happens on the first layer only, if happens later on too than no idea 😞

    I had similar pulsing (but lower frequency) with geared extruder where gears were badly printed, but that looks like too high frequency to be something like that...

    third issue, that I think is most likely happening to you is microstepping... especially cheap .9 motors are super imprecise with microstepping position so when you do for e.g. 1/8 instead of positions being:

    O.*.*.*.*.*.*.*.O.*.*.*.*.*.*.*.O.*.*.*.*
    

    they get something like

    O**.*...*...*.**O**.*...*...*.**O**.*...*
    

    so you push lot more plastic around the full step as microstepping crams around full steps ... the only solution I know off is getting a better motor or turning off microstepping (half stepping usually works ok)

    What I'd do is print a line in X and Y only and diagonal 45 degrees, measure wave length of the pulsing and then compare that to the slicer setting for first layer (layer height * line width) to see how many turns of the toothed drive in the extruder you have producing this pulses and also how many steps on the motor too ... might get you some interesting data ..



  • @smece that is an interesting theory. Layer 2 looks somewhat like layer 1 but I will do a test of several more layers to make sure. Im traveling with this printer and only have this pearlescent white with me that shows a lot though layers. I just tried E128 I0 to test no interpolation. Seems the same. Its an E3d pancake stepper. Not a Moon but should be ok. Other than to try a couple more layers, not sure what to try other than new motor.



  • I've seen that grouping of micro stepping positions on many steppers, that's not a new thing, and if you do more in-depth investigation you'll find that micro stepping is only meant to move motors smoother and quieter and you were never supposed to stop at those positions and expect accuracy. The fancy drivers now manage to, on decent motors, get us some accuracy there but that depends on so many factors..

    it might not be what's hitting you, as I said, measuring the wavelength of that pulse will give you data you can use to figure out why is that happening. I solved a bunch of similar "pulsing" artifacts by switching from microstepping to half step movements and gears



  • In response to your question I did 4 layers at .2mm. As you can see it’s still there in a nice cross hatch pattern. This was at E128 I0. I am traveling and didn't bring calipers so used the 1.75mm filament to estimate about .5-.6mm per pulse. Can you opine on my calcs here. .2 layerx.4widthx.6pulse=.048mm3 filament per pulse. Call it .05. Then 1 mm length of filament is 2.4 mm3 out the nozzle and there are 842 steps per mm at 1/16 microstepping so 8x842=6736 at 1/128 microstepping.
    2.4/.05=48 so 48 pulses in 1mm of filament. Then 6736 microsteps per 1mm of filament / 48=140 microsteps per pulse. Lets say I’m a bit off in my guess of pulse length so this is about 1 full step at 1/128.
    So my wild assed guess is about 1 pulse per whole step of the motor. Not sure what that means though???DCB2E167-4BD1-4484-9839-2838AA290FB0.jpeg



  • Also by the way, after power supply fix I retested what I thought was a failed E0 driver. It works. Must just have been the flaky power supply connection.


  • Moderator

    @4lathe Glad the board isn't damaged! I'm going to trust your calculations, too. If it's pulsing each full step, then it would seem that @smece might be right, and the movement of the motor isn't very linear. There is this monster thread where someone apparent problems with an E3D 0.9º motor on the extruder: https://forum.duet3d.com/topic/13264/prusa-upgraded-to-duet-weird-extrusion
    They seemed to resolve the problem by printing much faster! Otherwise, perhaps try a different motor?

    Ian



  • Thx for the reference. I found this also where he's having exactly the same problem. some motor talk in it and I don't really know what to make of it.
    https://forum.prusaprinters.org/forum/original-prusa-i3-mk3s-mk3-how-do-i-print-this-printing-help/fdm-printing-on-a-prusa-just-gets-interestinger-and-interestinger/



  • @4lathe said in Weird Ripples on My Maestro rrf3 Conversion:

    So my wild assed guess is about 1 pulse per whole step of the motor. Not sure what that means though???

    I'd say it means that you have more filament extruded at the full step position. The only reason why that would be that I can think of is that grouping of positions around the full step position. Now what is causing this grouping I have no clue, is it bad motor, bad psu, bad driver - no idea ...

    btw, when you drive motors with more current the microstepping positions seem to get more evenly spread out .. you can try increasing the current for the motors to see if the pattern will get less prominent



  • Any point in trying to change some parameters on drivers?


  • Moderator

    @4lathe said in Weird Ripples on My Maestro rrf3 Conversion:

    Any point in trying to change some parameters on drivers?

    You could try forcing spreadcycle. At the low speeds of the first layer you might be in stealthchop mode?



  • I printed a 2 perimeter open cube. Had vfa. M569 reported stealthchop. Set x stepper to spreadcycle. Reran. Same results. Also tried the same upping x current. Same. The only thing that made it almost entirely vanish was printing perimeters at 60mm/s. I guess this has been reported in other vfa threads. What I don't understand is why was I not getting this with klipper or on the stock board?


  • administrators

    It's unlikely but not impossible that the stepper driver that is driving the extruder motor is faulty. You can check this by switching to a different motor output. If the E1 output is free, then with power off move the extruder motor connector to that one. In config.g add M586 X0 Y1 Z2 E4 somewhere near the beginning (before the M906 and M350 commands). That will redirect extruder 0 to the E1 motor output.



  • Don't want to bear a dead horse but. I bought a ldo .9 stepper and tested it on a known good printer. No problem. I took the bondtech off that machine as a known good extruder. I put polycarbonate wheels on the ender 3 and adjusted everything including recalibrating extrusion and using a different filament. Then I started printing vase mode cubes that are 60mm tall and 50mm on a side looking for patterns. I made a script to increase speed from 20mm/s to 70mm/s every 10 vertical mm to see how speed affected it.
    It is all basically the same after all this. I also tried changing steppers from stealthchop to spreadcycle to random and constant. I also tried stealthchop but upped the cutoff speed at which it went to spreadcycle, thus forcing it to stay in stealthchop. None of this made any significant difference. This machine did not do this with the stock board but upgraded extruder in it. Im at a complete loss at this point as to what to try.
    Any thought much appreciated!



  • Sorry forgot the photos.86595C30-B9E7-43E4-853D-9C75767DD521.jpeg A9831520-61A4-4C23-ADC4-7C9BB4E54E74.jpeg


Log in to reply