Config.g setup for RRF 3.0



  • Sorry for all the spam! I feel like I've been posting all over these forums the past 24 hours.

    I just updated my board to RRF 3.0 from 1.19, and I'm working on updating my config file I keep running into issues with getting different things working the way I'd expect. Right now I'm struggling to get my temp sensor to give me a reading. I'm using a two-wire PT100, wired to my Duet Wifi through the PT100 daughter board. The RRF configuration tool is throwing me for a loop with all of the pin selections. I have 0 clue what I'm doing with my heaters/temp sensors setup. Currently, this is the heaters section of my config.g:

    ; Heaters
    M140 H-1                                             ; disable heated bed (overrides default heater mapping)
    M308 S0 P"spi.cs2" Y"rtd-max31865"            ; configure sensor 0 as thermocouple via CS pin spi.cs2
    M950 H0 C"e0heat" T0                                 ; create nozzle heater output on e0heat and map it to sensor 0
    M143 H0 S300                                         ; set temperature limit for heater 0 to 300C
    M307 H0 B0 S1.00                                     ; disable bang-bang mode for heater  and set PWM limit
    

    I don't have a bed heater. My nozzle's heater is wired to E0heat, and my 2-wire PT100 is wired to the middle 2 inputs on the PT100 daughter board (exactly the same way I had it wired with RRF 1.19). What pin do I need to assign in my M308 command for a PT100? In the RRF configuration tool, I've tried assigning it to e0temp, and the various MAX31856 on spi.csx. None of that has seemed to work



  • i don't know the PT100 daughter board but maybe this link will help you

    https://duet3d.dozuki.com/Wiki/Connecting_PT100_temperature_sensors#Section_Firmware_configuration


  • administrators

    @wcj97 said in Config.g setup for RRF 3.0:

    M308 S0 P"spi.cs2" Y"rtd-max31865" ; configure sensor 0 as thermocouple via CS pin spi.cs2

    Depending on which of the two inputs you are using, spi.cs1 or spi.cs2 is correct.

    When you send that command from the console, what response do you get?



  • @dc42 I got it figured out. Not sure what I was doing the first time around, but after playing with the config for a bit I finally went back to the RRF configurator and was able to get the proper setup. Everything is up and running now on RRF 3.0 and I'm loving it. Thank you again for all of the help over the past couple of days


Log in to reply