*SOLVED* Updating firmware results in The same firmware version?



  • This was completely My fault... I mis-read the github file, and jumped a bit too far ahead of myself.... Thanks to Danal for the assist!

    (Original Post) Hey Guys!

    I've never had an issue updating firmware before, and maybe It's because it's been a while, and I'm just doing something wrong...

    I downloaded the duet combined firmware from the 3.0 RC github, and when I go to system settings in my browser, and upload the file where it says to drag the firmware, it says it uploaded successfully, asks to restart, then it's still the same old 2.03 beta 3. Is there something Stupid I'm forgetting?

    I'm downloading the firmware here:
    https://github.com/dc42/RepRapFirmware/releases

    If I install this firmware, should I install the web control and wifi server as well first?

    These are my current builds:
    Firmware Name: RepRapFirmware for Duet 2 WiFi/Ethernet
    Firmware Electronics: Duet WiFi 1.02 or later + DueX5
    Firmware Version: 2.03beta3 (2019-03-25b6)
    WiFi Server Version: 1.21
    Web Interface Version: 1.22.6

    I see in the firmware section the file for duet expansion.. do I need to update that as well? is that the firmware for the Duex?

    Sorry for so many questions, but I've followed the "how to 5 or 6 times, and The version stays the same!

    As always, Thanks!



  • Maybe try the 3.0 release first, it has a complete set of supporting files.



  • I've had to install various intermediates. It is possible to read the release notes and figure everything out, but I find it faster just to install the "likely candidates".

    If your are on 2.03 (anything), I'd go 2.05.1 (latest 2.x), then 3.0, then 3.0-RC3.

    Again, there are probably things that could be skipped... but upgrading is SO FAST, I take the pragmatic approach.



  • @Danal said in Updating firmware results in...... The same firmware version?:

    2.05.1

    presumably you mean 2.05; 2.05.1 is in the same boat as say 3.01-RC3 incremental update.



  • That makes sense! Thanks, I didn't think of that.



  • Ugh! Updated each version incrementally, now nothing will even connect.

    I made it to 3.0, it connected, but anything connected to my duex was not detected.

    Now I cannot even connect via wifi. The paneldue shows that it's connected to wifi, but I cannot access it.

    I don't have a clue as to where to begin. I had a perfectly functional machine That I use for work every day. All I wanted to do was install a filament sensor...

    I'm reading the documents, and It seems that after 3.0, it gets really convoluted.

    I'm just super confused... I read the instructions to say that if I installed the Firmware zips, it would update all of the components necessary to run that particular build..

    Is there any way to back out again? Like, Where do i even begin to establish connection?

    Sorry to sound so helpless, but I just hosed myself. I can follow directions, and I thought I did... I refreshed the page, and that was it. I lost all connection.

    Thanks guys!



  • Baring physical damage, you can always recover with the usb port; on the other hand if you need the machine every day you may want to stay with the release versions and not the less tested release candidates.

    ref https://duet3d.dozuki.com/Wiki/Getting_Started_With_Duet_3#Section_Updating_Duet_3_main_board_firmware



  • If you were on 2.03, and need your printer daily, please do not even consider going to 3.anything until you have read all the documentation about how to convert your config.g and other required changes.

    Were I in your shoes, I'd go to 2.05.

    Power off duet, place SD card in PC, put "duet2combinedfirmware.bin" (from 2.05 download) in /sys, put card back in Duet, connect through USB and enter M997.



  • Yes, I use almost all of my machines to churn out parts every day for machines I manufacture. If I hook up with USB, I can simply update back to say... 2.5?

    I'm sorry, I run a 99% marlin shop. I have one machine running a duet, and it's my only large volume one. Bad on me for leaping before looking. I just need to get back to "good". I'll be up all night futzing with it. If you have any specific pointers for restoring connectivity, please let me know.

    As for the Duex.... The documentation does not mention any updates for them.. Is the reason that everything attached to them is not working the fact that 3.0 basically changes every M command to something else? I assume this renders all of my I/O useless until I learn how to re-map the whole thing?

    ooof!

    I'm sick to my stomach... Between Linux corrupting the main partition on my shop's storage server this week, and that it's been updating my cloud storage with a big garbled mess, and me making this boneheaded move, I've been my own worst enemy as of late.... Some days you're the windshield, some days you're the bug!





  • @Danal Thanks man! I appreciate it! On it now!



  • It's been a year since I've messed with this machine, so I'm pretty rusty... I'll get it I'm sure, I'm just panicky right now...



  • @Steve-Lynch said in Updating firmware results in...... The same firmware version?:

    Some days you're the windshield, some days you're the bug

    Yep, I've had those days.

    Duex is not working because 3 changes the syntax to define pins. And quite a few other things.

    Get back to 2.05 and it will all be OK with your existing config.g



  • Hey Danal, Thanks a ton! I'm back up... I had to step the wifi server version back, then I could connect again. Sometimes it's really nice to have a second set of eyes... The Ol' brain shuts off when I'm under pressure. I really sincerely appreciate you sparing me the obligatory lectures, and just saying "Dude! Do this!" I'll be sure to do my homework before hopping firmware versions again... Cheers!


Log in to reply