Supported Z probe types on expansion boards / tool boards


  • administrators

    IO1 should work, however IO0 is intended for the Z probe.

    I think the "stuck at 1000" is a firmware issue, I only tested with a bltouch, and I can see why that might behave differently. I will look into it.


  • administrators

    PS - possible workaround for now: repeat the M558 command in the deployprobe.g file



  • The workaround helps! I wasn't able to get my independent z axis leveling script to run, but running the commands individually worked.

    Thanks for your help!


  • administrators

    There is a new firmware build at https://www.dropbox.com/sh/3azy1njy3ayjsbp/AACquxr2m00eV568RZg5QG5wa?dl=0 which fixes the original problem. I have tested it using an IR sensor with both the IO0 and IO1 connectors. The fix is in the main board firmware. However, if you don't already have the new tool board firmware installed, you will need it when you come to use the tool board stepper motor.



  • I am currently not using the tool board stepper motor. Will give this a run and report back (-:



  • With the new firmware, G28 Z is stuck in an infinite repeat loop. OnlyM999stops this, with the unfortunate drawback that the machine isn't homed anymore after an emergency restart (I triedM0andM1` and they do not get executed).

    Here's my homez.g

    ; homez.g
    ; called to home the Z axis
    ;
    ; generated by RepRapFirmware Configuration Tool v2.1.8 on Fri Jan 31 2020 14:54:14 GMT+0100 (Mitteleuropäische Normalzeit)
    G91                  ; relative positioning
    G1 H2 Z5 F6000       ; lift Z relative to current position
    G90                  ; absolute positioning
    G1 X0 Y0 F6000       ; go to first probe point
    G30                  ; home Z by probing the bed
    
    ; Uncomment the following lines to lift Z after probing
    G91                 ; relative positioning
    G1 Z5 F100          ; lift Z relative to current position
    G90                 ; absolute positioning
    

    And here is my probe definition:

    ; Endstops
    M574 X1 Y2 S3 ; use stall guard for  XY endstops (X min, y max)
    M574 Z1 S2       ; configure Z-probe endstop for low end on Z
    
    ; Z-Probe
    M558 P8 C"10.io0.in" H5 F120 T600   ; set probe type, dive height + speed
    G31 P500 X-29 Y0 Z0.977             ; set Z probe trigger value, offset and trigger height
    M557 X-140:140 Y-140:140 P6         ; define mesh grid
    

  • administrators

    Are you running in standalone mode or with attached SBC?

    Does G30 sent from the console work OK?



  • I am running attached to an SBC. Just a G30 also loops.



  • G30 via pronterface does not loop. G30 via DWC loops.


  • administrators

    Thanks, I've fixed that now. New main board firmware file for you in the same place.



  • The new firmware does not loop anymore. I am happily printing!


Log in to reply