Help. Duet 0.8.5 not responding



  • hello, I finally converted my Rostock V2 to a Duet 085. I was able to install to the lates firmware from github and had it almost working, as in I was able to press home and the machined homed. I could also make it move down after homing.

    However, i coudn't level it which I wanted to be able to do before i installed the FSR. I also made the mistake of uploading the other firmware, such as core ay, raddbin, etc.. and after doing this, when i started the machine, it still recognized it as a duet on the web browser. I played with it like that trying to figure out how to get it working completely,

    Being confident that i got that far, I decided to delete everything on the SD CARD so that i could start over and load only the neccesary files. Once i did that, and inserted the SD card back into the duet 085 board, it stopped working and no more blinking. There's a green and red led beside the erase button and a red led stuck on when i plug my micro usb cable. It also seems that it doesn't respond to bossa anymore although it shows on the port and im able to write the Combinefirmware bin. Nothing blinks also. I thought i remembered it blinking.

    Have I bricked my board? MY gf got this for me as a present and it's brand new, except i never installed it. I was afraid this might happen.

    If anyone can help, that would be great. My friend also left his JTAG here and im not sure if that could help. The name is all i know about JTAG.

    sincerely,

    Alex



  • Should only need the micro (mini?) usb cable to recover any firmware related issues afaik even with the first generation Duet boards baring any physical damage.

    If you connect a usb cable, what does the device show up as?


  • administrators

    When you use Bossa to install the firmware, did you remember to check the Erase, Lock and Boot from Flash boxed before you clicked Write? Did it Verify OK?

    It's not normal for any of the LEDs on the Duet 085 to blink.



  • Did you rebuild the SD Card before putting it back in the Duet you say you deleted everything but don't say if you replaced any of the files?



  • ![0_1584100878143_bossa.png](Uploading 100%)

    Thank you for replying.

    That's what i thought also. But after I erased the SD and pasted correct files, it stopped working, and Yat keeps looking for port and then says it's busy. I've tried prontface, but no comm also. I've also uninstalled and installed everything again, but nothing.

    I've attached a screen shot.

    ![alt text](![0_1584100866934_bossa.png](Uploading 100%) image url)![0_1584101035164_WIN_20200313_05_03_28_Pro.jpg](Uploading 100%)



  • @dc42 yes



  • @Dougal1957 I did.
    i pasted:

    www
    sys- firmware here
    macros
    gcodes



  • This post is deleted!

  • administrators

    @amcutem said in Help. Duet 0.8.5 not responding:

    ![0_1584100878143_bossa.png](Uploading 100%)

    Thank you for replying.

    That's what i thought also. But after I erased the SD and pasted correct files, it stopped working, and Yat keeps looking for port and then says it's busy.

    That's usually a Windows issue, so you may need to reboot Windows. Make sure you don't have Bossa and YAT loaded at the same time.

    I've tried prontface, but no comm also. I've also uninstalled and installed everything again, but nothing.

    I've attached a screen shot.

    ![alt text](![0_1584100866934_bossa.png](Uploading 100%) image url)![0_1584101035164_WIN_20200313_05_03_28_Pro.jpg](Uploading 100%)

    Unfortunately your screen shot faied to upload. Please try again.



  • @amcutem did you also put a config.g file in the SYS Folder?



  • @Dougal1957

    Yes. I've done all that. Anything else?



  • @bearer

    it shoes up as bossa or duet. But i can't communicate with it.



  • @amcutem said in Help. Duet 0.8.5 not responding:

    @bearer

    it shoes up as bossa or duet. But i can't communicate with it.

    ? elaborate please, it doesn't make sense to be bossa or duet and not have communication - you need bossa software to communicate with bossa bootloader in the duet to make the board appear like a duet again. does that work?



  • Some of the older bossa/duet guides didn't mention explicitly specifying the com port in the command line argument. I needed that when I did it.


Log in to reply