investigating crush



  • I had a crush happen in my delta, twice with the same gcode. here is what happened:

    first layer worked well. when starting second layer, the head suddenly dived down and crushed into the bed. luckily the bed is on springs and I believe no damage occurred.
    in the second time, I repeated the same build. again first layer was ok and again at the beginning of the second layer a similar crush happened. this time I was with my hand on the switch and caught the event quickly.

    suspecting the gcode, I ran it through a viewer and found no errors or problems there.

    then I checked z level and it was 0 on contact with the bed, and would not move down below that.

    any ideas?



  • Was there a dramatic increase in print speed or travel move speed on that layer? Was the machine trying to do a travel move to/from an area near one of the towers?

    It sounds like a stalled motor / skipped steps, or perhaps some type of mechanical issue like a loose pulley. When a single motor loses position, the head will dive or rise.


  • Moderator

    @ooly did you look at the Gcode file on the Duet SD card? I’d suspect file corruption when uploaded.

    Ian



  • bot and droftarts,

    I apologize for not reacting until now. my computer was out in repair and I received it back only today.

    so first thank you for offering help.

    I have yet to go back to working with the printer but as for bot suggestion: I don't think there were stalled steps or speed changes. as I mentioned, in the second printing attempt there was no problem until the beginning of the second layer.
    droftarts: have not had a chance to look at the sd card. will do that later.



  • @ooly Often times, the first layer is intentionally slowed down by the slicer to make better first layer adhesion. The second layer can be sometimes twice the speed as the first, hence my question.

    When the effector ends up way highger or lower than it should be on a delta, it has definitely lost position. Whether it's a stepper losing position, or a mechanical issue is the question.



  • @bot
    thanks, bot. have not had a chance to explore the problem although I am a prisoner at home.


Log in to reply