Can't access wifi



  • @jens55 said in Can't access wifi:

    I haven't managed to figure out the subtle differences (if any) between M587 and M589.

    M587 is to connect to an AP, M589 is to provide an AP for you computer to connect to.

    (note, no quotation marks)

    not mandatory until RRF3 i think, so I just add them for good measure.



  • Ah, interesting, didn't know that the duet wifi could provide it's own access point. Cool

    Thanks, I will try M587

    Hmmm, there are no quotation marks in the gcode reference and I am running RRF3 ... I will add the quotation marks.



  • @jens55 said in Can't access wifi:

    Hmmm, there are no quotation marks in the gcode reference and I am running RRF3 ... I will add the quotation marks.

    I could well be wrong on that account, but here is somewhere qoutes are required for RRF3 and not RRF2 at least.

    edit: And for M587 you don't need to use I"0.0.0.0" to get a DHCP lease, only to override a previous static IP, as you used M588 S"*" that should render that a moot point.



  • No dice with switching to M587
    I will try and remove the "i" bit



  • Oh crap ... left the dashes in the config.g file .... it's been a rough day 🙂
    will try again!



  • Haha, the I shouldn't be a problem, but removing it would remove any doubt about qoutes, thats why I mentioned it.

    what i should have typed:
    m589 s"---------" P"-------------" i00.00.00.00
    should be either
    M587 S"---------" P"-------------" ;Connects to SSID --------
    M552 S1
    or
    M589 S"---------" P"-------------" I"196.168.10.1" ;Creates SSID ----- and offers DHCP addresses in 192.168.10.0/24
    M552 S2



  • Still no joy 😞



  • Do you have a panelDue? if so create a macro and run that from the screen.

    if not, create a trigger and attach it to an endstop and then have the wifi code in that?

    edit: or usb and serial terminal is also good and interactive.



  • No I don't but just came up with another thought - I will need to give the M587 a letter salad in order to preserve the case of the letters.
    Here goes nothing .... crossing fingers ....



  • @jens55 said in Can't access wifi:

    I will need to give the M587 a letter salad in order to preserve the case of the letters.

    I was under the impression that was only needed for something like ponterface which translates all g-code to upper case? Still using ' to force them lowercase should work regardless of serial or config file methinks. I just seem to recall there is something preventing it from enabling the wifi module until after config.g is done. (maybe M552 S0 takes care of that idk)



  • Yes, I was under the same impression ....
    and the rest of the config.g includes an M552S1

    and

    No dice, that would have been too easy ....



  • Time to pack it in for the night. Maybe some other people will chime in overnight.
    Thanks for your help!



  • That ***** me off... so I tried on a board here.

    Think the second G4 is redundant, but uncomment if it still doesn't work. Confirmed working from config.g even though its baaaaaad mojo.

    M552 S-1
    M552 S0 ; take AP out of reset, just in case
    G4 S1
    M588 S"*"; forget all previous access point info
    ;G4 S1
    M587 S"---" P"---" 
    M552 S1
    


  • (Culprit was something in the lines of failed to bring wifi out of reset code -7 or something like that, which showed up on the serial port and paneldue.

    oh, found the serial terminal still open, will add output in case people go searching.

    WiFi module started                                                             
    M587: Failed to add SSID to remembered list                                     
    Turn off the current WiFi mode before selecting a new one                       
    Error: Failed to initialise WiFi module, code -7      
    

    Next time grab a usb cable:))



  • Thanks, I will give it a try tomorrow morning.
    Interesting about adding dwell times - I would have never thought about that but it makes sense ! I will also try with and without M552 S-1 as I am thinking that S0 should be ok ... but don't know for sure.
    If I do grab a usb cable and even plug it in on both ends, then what? Do I load a terminal program ? I am running Linux btw. Never tried that before.



  • @jens55 said in Can't access wifi:

    ! I will also try with and without M552 S-1 as I am thinking that S0 should be ok

    some wifi modules say failed to add network bad format or something like that; the S-1 is just a potential safeguard against that, it won't hurt at least.



  • @jens55 said in Can't access wifi:

    Do I load a terminal program ? I am running Linux btw.

    yeah, screen, minicom or picocom should work.

    do dmesg | tail to see what /dev/tty* device the new serial port is called. Probably something like /dev/ttyUSB0 or /dev/ttyAMA0 depending on your distro and the angle of the moon.


  • Moderator

    @jens55 what firmware version? There’s a bug in early RRF3 versions that doesn’t save the password. Use latest 3.01 RC4. M552 S-1 turns off Wifi, so you can’t add SSID, needs to be in idle mode S0. Though turning off, then idle mode, before sending SSID and password can help.

    Ian



  • I am running RRF 3.01-RC3
    When hooking up via USB I get something in the line of "no known network found" so I am assuming I have to go to RC4.
    SInce I can't update through DWC, which files do I need to put onto the memory card directly to do the upgrade ?

    Edit: I copied Duet2CombinedFirmware.bin over to the memory card but there was no change.

    Edit 2: serial port running M587 seems to report no networks found so maybe the upgrade to RC4 did not complete ?



  • @bearer , thanks for the instructions re connecting USB - worked great. Still not up and running but I am sure that's just the RC4 upgrade.
    Thanks again for all your help!


Log in to reply