Can't access wifi

  • @jens55 said in Can't access wifi:

    Hmmm, there are no quotation marks in the gcode reference and I am running RRF3 ... I will add the quotation marks.

    I could well be wrong on that account, but here is somewhere qoutes are required for RRF3 and not RRF2 at least.

    edit: And for M587 you don't need to use I"" to get a DHCP lease, only to override a previous static IP, as you used M588 S"*" that should render that a moot point.

  • No dice with switching to M587
    I will try and remove the "i" bit

  • Oh crap ... left the dashes in the config.g file .... it's been a rough day 🙂
    will try again!

  • Haha, the I shouldn't be a problem, but removing it would remove any doubt about qoutes, thats why I mentioned it.

    what i should have typed:
    m589 s"---------" P"-------------" i00.00.00.00
    should be either
    M587 S"---------" P"-------------" ;Connects to SSID --------
    M552 S1
    M589 S"---------" P"-------------" I"" ;Creates SSID ----- and offers DHCP addresses in
    M552 S2

  • Still no joy 😞

  • Do you have a panelDue? if so create a macro and run that from the screen.

    if not, create a trigger and attach it to an endstop and then have the wifi code in that?

    edit: or usb and serial terminal is also good and interactive.

  • No I don't but just came up with another thought - I will need to give the M587 a letter salad in order to preserve the case of the letters.
    Here goes nothing .... crossing fingers ....

  • @jens55 said in Can't access wifi:

    I will need to give the M587 a letter salad in order to preserve the case of the letters.

    I was under the impression that was only needed for something like ponterface which translates all g-code to upper case? Still using ' to force them lowercase should work regardless of serial or config file methinks. I just seem to recall there is something preventing it from enabling the wifi module until after config.g is done. (maybe M552 S0 takes care of that idk)

  • Yes, I was under the same impression ....
    and the rest of the config.g includes an M552S1


    No dice, that would have been too easy ....

  • Time to pack it in for the night. Maybe some other people will chime in overnight.
    Thanks for your help!

  • That ***** me off... so I tried on a board here.

    Think the second G4 is redundant, but uncomment if it still doesn't work. Confirmed working from config.g even though its baaaaaad mojo.

    M552 S-1
    M552 S0 ; take AP out of reset, just in case
    G4 S1
    M588 S"*"; forget all previous access point info
    ;G4 S1
    M587 S"---" P"---" 
    M552 S1

  • (Culprit was something in the lines of failed to bring wifi out of reset code -7 or something like that, which showed up on the serial port and paneldue.

    oh, found the serial terminal still open, will add output in case people go searching.

    WiFi module started                                                             
    M587: Failed to add SSID to remembered list                                     
    Turn off the current WiFi mode before selecting a new one                       
    Error: Failed to initialise WiFi module, code -7      

    Next time grab a usb cable:))

  • Thanks, I will give it a try tomorrow morning.
    Interesting about adding dwell times - I would have never thought about that but it makes sense ! I will also try with and without M552 S-1 as I am thinking that S0 should be ok ... but don't know for sure.
    If I do grab a usb cable and even plug it in on both ends, then what? Do I load a terminal program ? I am running Linux btw. Never tried that before.

  • @jens55 said in Can't access wifi:

    ! I will also try with and without M552 S-1 as I am thinking that S0 should be ok

    some wifi modules say failed to add network bad format or something like that; the S-1 is just a potential safeguard against that, it won't hurt at least.

  • @jens55 said in Can't access wifi:

    Do I load a terminal program ? I am running Linux btw.

    yeah, screen, minicom or picocom should work.

    do dmesg | tail to see what /dev/tty* device the new serial port is called. Probably something like /dev/ttyUSB0 or /dev/ttyAMA0 depending on your distro and the angle of the moon.

  • Moderator

    @jens55 what firmware version? There’s a bug in early RRF3 versions that doesn’t save the password. Use latest 3.01 RC4. M552 S-1 turns off Wifi, so you can’t add SSID, needs to be in idle mode S0. Though turning off, then idle mode, before sending SSID and password can help.


  • I am running RRF 3.01-RC3
    When hooking up via USB I get something in the line of "no known network found" so I am assuming I have to go to RC4.
    SInce I can't update through DWC, which files do I need to put onto the memory card directly to do the upgrade ?

    Edit: I copied Duet2CombinedFirmware.bin over to the memory card but there was no change.

    Edit 2: serial port running M587 seems to report no networks found so maybe the upgrade to RC4 did not complete ?

  • @bearer , thanks for the instructions re connecting USB - worked great. Still not up and running but I am sure that's just the RC4 upgrade.
    Thanks again for all your help!

  • Moderator

    @jens55 it was fixed in 3.01 RC1, so it’s not that. Sounds like non-alphanumeric characters in SSID or password is the most likely issue, but have had a couple of problems with new router hardware. See this other thread:

    Also, check how serial comms are set up

    There was also a thread about Linux using non-standard codes for some characters, but I think it was the same thread as in the above paragraph.

    Finally, if the SSID is hidden, you need to specify it when enabling networking, eg M552 S1 S"ssid"


  • While I normally like a challenge, this is getting hard on my forehead and the drywall from too much bashing my head against the wall.
    I still can't see the device in my 'connected devices' list on either network
    I have now changed the network to be visible.
    There is a tiny bit of good news, the serial connection now gives me:
    failed trying to connect to "-----" , wifi module is idle

    As I said, I have one non alphanumeric character in the password, a period ..... ?????

    Edit: the ssid it is trying to connect to is the correct ssid

  • @jens55 said in Can't access wifi:

    failed trying to connect to "-----" , wifi module is idle
    As I said, I have one non alphanumeric character in the password, a period ..... ?????

    beyond "bug" that should leave only signal strength and encryption.

    a period shouldn't pose a problem neither for RRF or your linux terminal but share the details of which terminal you went with and I can try it (also if the period is first, last or in the middle of the key just for good measure)

  • Plenty of signal and no interference. The network uses wpa2 personal, period is in the middle. I used puTTY as the terminal program. The terminal program is configured for 9600 8 1 but does show occasional odd characters but is of course only used as an additional source for diagnostic. It is however annoying that the duet spits out a more or less continuous stream of text which may or may not indicate that something is misconfigured. I can however enter commands in a fashion and get a proper terminal response (in amongst the text the duet is constantly streaming)
    I have set things aside for now as sometimes I can't see the obvious when I get so wound up.

  • @jens55 said in Can't access wifi:

    The terminal program is configured for 9600 8 1 but does show occasional odd characters

    special case so don't think the baud rate matters for this, but I generally leave it at 57600 in case I want to use the PanelDue port where it does matter. But I don't think I've seen any garbled data from the Duet usb serial, the connection is lost when the Duet resets but unless the garbled data is tied to resets its a bit of a concern.

    i'll give it a go when i'm back if its not sorted by then

  • Making some odd progress ...
    I am not getting the constant flow of characters from the duet on the serial port any more and only the first command to the duet has a garbeled character in it. So ....
    I have removed all the extras out of config.g that were set up to try and get this thing going.
    I manually, through the serial port, gave it the right ssid and password. I also set up a static IP on the router.
    I now get two (!!!) entries in the client list on the correct network. One has the correct ip and is not properly connected, the other is as ip but it shows as connected with good signal.
    Well I can't get to with my browser but I can get to the correct ip number where I get a picture similar to what I should see but greyed out and it's trying to connect but can't.
    I tried giving the ip number in the M587 command in quotation marks and that was a no go (invalid IP number) and then tried the same with no quotation marks and duet accepted that.
    I now get the proper ssid and the proper IP number when I give the M587 command but I still have two entries in my router for connected clients. I have no idea what's going on or how this could happen.
    My next kick at the cat will be to try forgetting everything and then re-entering the ssid and password .

  • Everything erased and re-entered. Wifi shut down to erase the entry. Wifi brought back up and confirmed all entries for the duet are gone.
    As soon as I turned on power to the duet, both ip numbers show up with being the connected ip address and the being the not connected number. When I direct the browser to, I get the right web screen but the console tells me "failed to connect to"

Log in to reply