Radds Bltouch configuration



  • So I have been trying to get my BLTouch sensor working with reprap firmware on radds but have been unsuccessful. I currently have the black and white pins connected to z min, and the other 3 pins connected to pin 39 or PWM3 on Radds. From my understanding reading other bltouch related threads, M558 P4 uses pin 39 while M558 P5 uses pin 5. In the z probe documentation for reprap firmware it says to use P5 for the BLTouch however most people use P4. I have tried both P5 and P4 however I cannot figure out which pin on Radds is pin 5. Whether I use P4 or P5 the Bltouch does not respond to any of my commands even the retract and deploy probe commands. Whenever I try to home Z, I get an error saying something like the probe is already at min. One thing I noticed is if i turn on the printer normally, M119 returns z min: at min stop, z probe: at min stop. However if i turn on the printer and hold the bltouch pin to put it in the error state, then M119 returns z min: not stopped z probe: at min stop. I also am not using the bltouch's 3.3v logic because its stealing 5v from an lcd pin and that seemed to have worked before with marlin. I know for the Duet the 3.3v logic needs to be turned on but should I turn it on in this case? I believe the problem with the bltouch lies in the config.g trying to communicate through a different pin but I'm not sure. Please let me know what you think.

    config.g

    [[language]]
    M307 H3 A-1 C-1 D-1
    M558 P5 X0 Y0 Z1 H3 F200 T5000
    G31 X-20.0 Y20.0 Z0 P25
    
    

    homez.g```
    [[language]]
    G28 X Y
    G90
    G1 X120 Y130
    M98 Pdeployprobe.g
    G30 S-1
    M98 Pretractprobe.g

    
    deployprobe.g
    

    [[language]]
    M280 P3 S10 I1

    retractprobe.g```
    [[language]]
    M280 P3 S90 I1
    
    


  • sounds like your Z endstop logic needs to be inverted,

    When the BLTouch is in an error state it holds itself as being triggered. Thats at least part of your problem.

    As to the signal pin to trigger the BLtouch you should try M280 P# S10 I1 replace # with whatever P you are trying to use and maybe try others as well. That gcode command should drop the pin on the bltouch is raised

    S90 will raise it
    S120 will self test
    S160 will reset an error state(blinking)



  • P3 is the only one that doesnt give me an invalid servo index for M280 and that doesnt work. The issue is radds actually uses heater 3. H3's pin is 21. I think to fix my issue I need to direct M558 to pin 39 instead of heater 3 in order for it to work.


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.