G1 H2 command not working



  • Hi, i encountered something weird, on the last version of RRF3 (3.01-RC5), i cannot make my homes without sending a M564 H0, didn't realize it before because i'm using the M564 H0 really often and almost never restart the printer, i realize it when i done a rebbot and then, homeall.g failed, "G0/G1: insufficient axes homed". I join my home all code for you to see even if it worked since a while 🙂

    M80
    M400

    M915 X S2.4 F0 R0
    M915 Y S2.6 F0 R0
    M574 X1 Y1 S3
    M913 X30 Y30

    G91
    G1 H2 X5 Y5 Z5 F600
    G1 H1 X-325 Y-325 F3600
    M913 X100 Y100
    G90
    G1 X125 Y105 F12000
    M400
    G91
    G1 H1 Z-300 F600
    G1 Z5 F600
    G90
    G30

    M915 X Y S8 F0 R1
    M501



  • can you enter the commands individually at the console and see which fails? They all work for me... but I am on RC4.



  • I just solved the problem ._. So i needed to add a G4 S1 to wait a bit after the power supply goes on with M80, if not, it tries to do the moves undervoltage and then the coordinates goes at -300 or something like that and block the board, until you reset it, or do a G92 X0 Y0 Z0.
    So just a problem with the using of a relay ^^ weird that it always worked before ^^



  • Nice find, and great that it is working now.


Log in to reply