I think my new Magnetic Filament Monitor is dead.



  • I really hope its just something I’ve done wrong, but it has become unresponsive after giving some truly crazy data.

    After installing the monitor everything looked pretty good at first. Then it quickly started pausing every couple of minutes to the point that I had to stop the print. I turned it off and disconnected the MFM due to wanting to actually print. Then hooked it back up after a couple days to see if I could get working. That’s when the numbers went form promising to crazy.

    I’m attaching some screenshots that might help. But basically it paused a lot, so I opened up the movement bounds. Then it got more and more out of bounds until it went crazy. Then gave me an error 6 and the lights shut off and it wont respond.
    IMG_0491.jpeg

    IMG_0501.jpeg

    IMG_0502.jpeg
    This is how I had it mounted if that helps.
    IMG_2948.jpeg


  • Moderator

    Can I get you to confirm your firmware version, the filament monitor version, how you have it wired, and how it's configured?

    https://duet3d.dozuki.com/Wiki/Duet3dFilamentMonitor_RotatingMagnetVersion



  • IMG_0516.jpeg

    IMG_3088.jpeg

    IMG_3090.jpeg

    IMG_3091.jpeg

    Screen Shot 2020-04-22 at 14.25.23.jpeg



  • Thank you for the help.


  • Moderator

    @shinook said in I think my new Magnetic Filament Monitor is dead.:

    Then gave me an error 6 and the lights shut off and it wont respond.

    Just to confirm, there is no status LED lit on the monitor anymore?

    Did you happen to notice the sequence of flashes when it was working?



  • They weren’t flashing since last night, but after I shut it down and back on to get those pics, the lights are flashing again. Without running the printer, just letting it be powered on, the lights flash three long green when turned on, and then green - red -greed - red. While printing, it was just flashing green.


  • Moderator

    Alright, so based on this, 3 green at startup means the magnet is detected correctly. That's good. Red and Green means it's communicating with the Duet, that's good. And flashing while printing is good as well.

    Can you try running the calibration on it again?

    https://duet3d.dozuki.com/Wiki/Duet3dFilamentMonitor_RotatingMagnetVersion#Section_Status_indication_LEDs

    Status indication LEDs
    In normal operation the filament monitor will flash the green LED 3 times to indicate the magnet is detected. The green LED will then flash periodically red and green indicating communication to the Duet (the green flashes are position reports, the red ones are status reports). If the magnet is rotating the green LED will flash more frequently (can look like almost solid green)

    If the filament monitor fails to initialise after power up, then instead of flashing the green LED 3 times it will flash the red LED to indicate an error. It will continue to try to initialise and flash the red LED until successful initialisation.

    The number of flashes of the red LED indicates the nature of the error, as follows:

    4 flashes: I2C communications error
    5 flashes: I2C channel is in an incorrect state
    6 flashes: Magnet not detected. Typically this means that the magnet is too far away from the sensor chip.



  • Will do. Thank you.



  • Thank you for your help.
    I was just now able to successfully print a test cube without a single pause. I guess it just needed me to give up on it before it would put forth its best effort....

    F0020538-8197-413A-BD78-11B727689DB8.jpeg

    I guess that calibration looks good? I’ll go ahead and try a larger print now.
    Thank you again for the help.
    -Isaac



  • Oh, do I put that 25.10mm/rev into my config.g now?


  • Moderator

    Yes I think so based on this:

    Calibration
    If you haven't done so already, send the M591 command with the correct parameters to tell the firmware about the sensor.
    Run M591 D# where # is the extruder number and check that the sensor angle is reported, to confirm that communication from the filament monitor to the Duet is working.
    Start a print.
    During and after the print, as soon as sufficient filament has been extruded you can use M591 D# (where # is the extruder number) to report the measured mm/rev averaged over the print thus far, and its variation.
    If you pause and then resume the print, calibration will be re-started and the values accumulated from before you paused will be discarded.
    The mm/rev value goes into the L parameter of the M591 command. Use a positive or negative sign as reported by M591. Set the R (tolerance) parameter to somewhat more than the reported variation.


  • Moderator

    @shinook said in I think my new Magnetic Filament Monitor is dead.:

    I guess it just needed me to give up on it before it would put forth its best effort....

    Sometimes that's the way it goes.



  • So, got more pauses and an “Extruder 0 report sensor not working” error. It’s otherwise working great. But, not sure what to do. Having my printer stop because of the sensor is getting frustrating.

    020B9EFF-0F4E-4749-9E0A-ED15C6EBE95D.png


  • administrators

    1. A screen shot in one of your previous posts showed that you are running firmware 2.05. Please upgrade to firmware 2.05.1. It might fix the issue, although more likely it won't.

    2. Please keep a close eye on the AGC value reported by M591. If it goes much above 100 then we'll replace your filament monitor.



  • Ok. I’ll update the firmware.



  • Update the firmware.
    I keep getting random pauses from “too much” or “too little” movement. Though they aren’t as common as the good old “ sensor not working”. My AGC is still in the low 90’s. And every time I check the status of the monitor(while its working) the results are between 99% and 103%.

    Honestly, it’s causing more problems than its worth. If I can’t get it to stop pausing my prints, I’ll need to find a more reliable monitor.


  • administrators

    @shinook said in I think my new Magnetic Filament Monitor is dead.:

    I keep getting random pauses from “too much” or “too little” movement.

    What do you have the min and max allowed percentages set to?



  • 70% to 130%



  • It’ll work great for multiple prints, then pause a 3 hour print 5 times.


  • administrators

    Have the "sensor not working" errors gone completely, or not?


Log in to reply