Extruders, heaters and temp probe not working



  • Can anyone shed some light on our current config file? All of the motors are currently working, except for the extruders, along with the heaters and temp probes (we have tried thermocouples and thermistors). We do have a daughter board but not tried it yet

    We started off using the online configuration tool, but have had to change plenty of things to get it working, but it is just this problem (which is hopefully something simple).
    The extruder has worked in the past when we initially got everything talking and running a gcode, but they only turned at the end of the print (that was before we changed the config)

    ; Configuration file for Duet WiFi (firmware version 1.17)
    ; executed by the firmware on start-up
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Mar 27 2017 16:43:36 GMT+0100 (GMT Daylight Time)

    ; General preferences
    M111 S0 ; Debugging off
    G21 ; Work in millimetres
    G90 ; Send absolute coordinates…
    M83 ; ...but relative extruder moves
    M555 P2 ; Set firmware compatibility to look like Marlin
    M208 X0 Y0 Z0 S1 ; Set axis minima
    M208 X1200 Y2300 Z900 S0 ; Set axis maxima

    ; Endstops
    M574 X1 Y1 Z1 S0 ; Define active high microswitches
    M558 P1 X0 Y0 Z0 H5 F120 T9000 ; Set Z probe type to unmodulated, the axes for which it is used and the probe + travel speeds
    G31 P600 X0 Y0 Z2.5 ; Set Z probe trigger value, offset and trigger height
    M557 X15:2285 Y15:2085 S20 ; Define mesh grid

    ; Drives
    M584 Z5 ; Apply custom drive mapping
    M569 P0 S1 ; Drive 0 goes forwards
    M569 P1 S1 ; Drive 1 goes forwards
    M569 P5 S0 R1 T2 ; Drive 2 goes forwards
    M569 P3 S1 ; Drive 3 goes forwards
    M569 P4 S1 ; Drive 4 goes forwards
    M350 X16 Y16 Z10 E16:16 I1 ; Configure microstepping with interpolation
    M92 X213.33 Y213.33 Z5000 E495:495 ; Set steps per mm
    M566 X900 Y900 Z50 E120:120 ; Set maximum instantaneous speed changes (mm/min)
    M203 X48000 Y48000 Z100 E1200:1200 ; Set maximum speeds (mm/min)
    M201 X100 Y100 Z20 E50:50 ; Set accelerations (mm/s^2)
    M906 X2000 Y2000 Z2000 E600:600 I30 ; Set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Heaters
    M143 S260 ; Set maximum heater temperature to 260C
    M140 H-1 ; Disable heated bed
    M305 P1 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 1
    M305 P2 T100000 B4138 C0 R4700 ; Set thermistor + ADC parameters for heater 2

    ; Tools
    M563 P0 D0 H1 ; Define tool 0
    G10 P0 X0 Y0 Z0 ; Set tool 0 axis offsets
    G10 P0 R0 S0 ; Set initial tool 0 active and standby temperatures to 0C
    M563 P1 D1 H2 ; Define tool 1
    G10 P1 X0 Y0 Z0 ; Set tool 1 axis offsets
    G10 P1 R0 S0 ; Set initial tool 1 active and standby temperatures to 0C

    ; Network
    M552 S0 ; Disable network

    ; Fans
    M106 P0 S0.3 I0 F500 H-1 ; Set fan 0 value, PWM signal inversion and frequency. Thermostatic control is turned off
    M106 P1 S1 I0 F500 H1:2 T45 ; Set fan 1 value, PWM signal inversion and frequency. Thermostatic control is turned on
    M106 P2 S1 I0 F500 H1:2 T45 ; Set fan 2 value, PWM signal inversion and frequency. Thermostatic control is turned on

    ; Custom settings are not configured

    I have just looked at the tfree, tpost, tpre files and I am guessing that they are the issues, but not sure what needs to go in there.
    tfree is
    ; tfree0.g
    ; called when tool 0 is freed
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Mar 27 2017 16:43:36 GMT+0100 (GMT Daylight Time)

    tpost is
    ; tpost0.g
    ; called after tool 0 has been selected
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Mar 27 2017 16:43:36 GMT+0100 (GMT Daylight Time)

    ; Wait for set temperatures to be reached
    M116 P0

    tpre is
    ; tpre0.g
    ; called before tool 0 is selected
    ;
    ; generated by RepRapFirmware Configuration Tool on Mon Mar 27 2017 16:43:36 GMT+0100 (GMT Daylight Time)



  • It wont be those files, it appears that you might have a default thermisistor settings. Have you tried targeting your specific thermocouple or thermisistor?

    Knowing the correct OHMs at room temp and full temp then plugging those into the calculator on the online configurator will go along way.

    You should then be able to run autotune on each of the heaters.


  • administrators

    Please can you clarify in what way(s) the heaters and temperature probes are not working. Are you selecting a tool before trying to heat up the extruder(s)?


Locked
 

Looks like your connection to Duet3D was lost, please wait while we try to reconnect.