Temperatur Channels Error Duet Maestro after upgrade to RRF3



  • Hi,
    I've just upgraded my Maestro from the old 2.2 to the new Firmware via the online configurator, but for some reason my extruder and hotbed thermistor show 2000°C and I get the following error:

    Error: Temperature reading fault on heater 1: unknown temperature sensor channel

    It worked perfectly before the upgrade, but to be sure I checked and there is no open circuit.
    I'm not exactly an expert with GCode configuration, but from what I can see there is no error in the gcode. I used the profile for the Anet A8 and changed the thermistor settings to the one for my V6 Hotend (Only the bed thermistor is connected, I won't risk using the A8 Bed cause fire hazard, so it doesn't matter how that one is configured)

    I'll attach both the old and the new config.g files, maybe one of you can help me.

    config old.g

    config.g

    Thanks in advance


  • Moderator

    Please send M115 and see what firmware version you actually have installed.



  • Good idea, I forgot about the problems with 3.01 and tried to update directly.
    I've now gone to 3.0 and after that to 3.01 and now everything is fine.

    Thank you


Log in to reply