Error on heightmap display



  • Something new happening.
    Been trying to set maximum area to run mesh grid, but all of a sudden I am getting the following error when it tries to display the mesh grid :


    Javascript Error

    A JavaScript error has occurred so the web interface has closed the connection to your board. It is recommended to reload the web interface now. If this happens again, please contact the author and share this error message:

    Version: 1.22.6
    Message: TypeError: r is null
    URL: http://192.168.0.221/js/dwc.js
    Line: 15:296246
    Error object: {}


    It does save the height map in the Heightmap.csv file so I can still print.


    RepRapFirmware height map file v2, mean error 0.071, deviation 0.097
    xmin,xmax,ymin,ymax,radius,xspacing,yspacing,xnum,ynum
    15.00,275.00,20.00,275.00,-1.00,50.00,50.00,6,6
    0, -0.053, -0.028, -0.014, -0.076, -0.131
    0, -0.013, 0.036, 0.071, 0.032, -0.046
    0, 0.071, 0.111, 0.134, 0.097, 0.007
    0, 0.124, 0.182, 0.200, 0.160, 0.060
    0, 0.155, 0.217, 0.232, 0.180, 0.072
    0, 0, 0, 0, 0, 0


    It errors when the heightmap is displayed and closes the connection to the duet.
    I took the numbers back to the original, but it does it all the time now.

    Config.g if it helps :


    ; General preferences
    G90 ; send absolute coordinates...
    ;M83 ; ...but relative extruder moves
    M550 PHevo 300 ; set printer name

    M667 S1 ; select CoreXY mode

    ; Network
    M552 S1 ; enable network
    M555 P1 ; Set firmware compatibility to look like RepRapFirmare
    ;*** Access point is configured manually via M587
    M586 P0 S1 ; enable HTTP
    M586 P1 S0 ; disable FTP
    M586 P2 S0 ; disable Telnet

    ; Drives
    M569 P0 S1 ; Drive 0 goes backwards X
    M569 P1 S1 ; Drive 1 goes backwards Y
    M569 P2 S0 ; physical drive 2 goes Forwards Z
    M569 P3 S1 ; physical drive 3 goes backwards E0
    M569 P5 S0 ; physical drive 5 goes Fowrards Z2
    M584 X0 Y1 Z2:5 E3 ; set drive mapping
    M671 X-56:318 Y154:154 S4.0 ; define Z screw locations, 4mm max compensation
    M350 X16 Y16 Z16 E16 I1 ; configure microstepping with interpolation
    M92 X80.00 Y80.00 Z400.00 E410.00 ; set steps per mm
    M566 X500.00 Y500.00 Z35.00 E120.00 ; set maximum instantaneous speed changes (mm/min)
    M203 X15000.00 Y15000.00 Z2000.00 E2000.00 ; set maximum speeds (mm/min)
    M201 X800.00 Y800.00 Z500.00 E800.00 ; set accelerations (mm/s^2)
    M906 X800 Y800 Z800:800 E800 I30 ; set motor currents (mA) and motor idle factor in per cent
    M84 S30 ; Set idle timeout

    ; Axis Limits
    M208 X15:275 Y10:275 Z0:280 ; set axis Limits

    ; Endstops
    M574 X2 Y1 S1 ; set active high endstop. Z Set below

    ; Heaters
    M307 H0 B0 S1.00 ; disable bang-bang mode for the bed heater and set PWM limit
    M305 P0 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 0
    M143 H0 S120 ; set temperature limit for heater 0 to 120C
    M305 P1 T100000 B4138 R4700 ; set thermistor + ADC parameters for heater 1
    M143 H1 S280 ; set temperature limit for heater 1 to 280C

    ; BLTouch
    M574 Z1 S2 ; Define Z to use Probe. Home to Min
    M558 P9 H5 F500 T3000 A5 ; set Z probe type to BLTouch and the dive height + speeds Probe up to 5 times .03 tolerance
    G31 P25 X20 Y-14 Z2.66 ; set Z probe trigger value, offset and trigger height
    M557 X15:275 Y20:275 S50 ; define mesh grid
    M307 H5 A-1 C-1 D-1 ; Disable the 5th Heater to free up PWM channel 5 on the Duex board. 7 Does not seem to work.

    ;IR Z-Probe
    ;M558 P1 X0 Y0 Z1 H4 F500 T3000 R0 A5 S0.02 ; set Z probe type to unmodulated and the dive height + speeds Probe up to 5 times .03 tolerance
    ;G31 P500 X0 Y10 Z2.4 ; set Z probe trigger value, offset and trigger height
    ;M557 X0:275 Y0:275 S66 ; define mesh grid
    ;M376 H5 ; set bed compensation taper 5mm

    ; Fans
    M106 P0 S0 I0 F500 H-1 ; set fan 0 value, Part Cooler, PWM signal.inversion and frequency. Thermostatic control is turned off
    ;********************** MOSFET IS FRIED M106 P1 S0.75 I0 F500 H1 T45 ;set fan 1 value, Tool Fan, PWM signal.inversion and frequency. Thermostatic control is turned on at 45c
    M106 P2 S1 I0 F500 H1 T45 ; set fan 2 value, Tool Fan, PWM signal.inversion and frequency. Thermostatic control is turned on at 45c
    M106 P4 S0.50 I0 F500 H1 T35 ; set fan 4 value, CPU, PWM signal.inversion and frequency. Thermostatic control is turned on at 35c
    M106 P3 S1 I0 F500 H1 T45 ; set fan 3 value, Hepa Filter, PWM signal.inversion and frequency. Thermostatic control is turned on at 45c.

    ; Tools
    M563 P0 D0 H1 ; define tool 0
    G10 P0 X0 Y0 Z0 ; set tool 0 axis offsets
    G10 P0 R0 S0 ; set initial tool 0 active and standby temperatures to 0C

    ; Custom settings are not defined

    ; Miscellaneous
    M501 ; Load config-override parameters.
    T0 ; select first tool



  • Moderator

    I think you may need to update your firmware and DWC versions. What are you currently running?



  • Firmware Version: 2.02(RTOS) (2018-12-24b1)
    WiFi Server Version: 1.22
    Web Interface Version: 1.22.6

    Been Running for months, Have not updated anything.
    I have switch to firefox recently. Did not have this problem till today.

    OK, switch back to chrome just to test and it works there.
    I locked a few things down in firefox for a little more security, must have changed something it doesn't like.


  • Moderator

    You may want to try updating your firmwares as you're all a bit out of date. If everything is running smoothly and changing the browser has solved the issue maybe you want to stay where you're at. Check the release notes between 2.02 and 2.05 to see if there's anything you might benefit from.

    https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05

    If you do want to update, upload the zip file from 2.05 release to update your firmware, wifi, and DWC versions.

    There is also a bug fix release for the firmware and update for the DWC in 2.05.1

    https://github.com/Duet3D/RepRapFirmware/releases/tag/2.05.1



  • Will Check it out, thanks.


  • Moderator

    I forgot to include this link regarding firmware update: https://duet3d.dozuki.com/Wiki/Installing_and_Updating_Firmware


Log in to reply